Wheel No longer working

Hi
So I recently updated my 2 year old Thrustmaster TX to the latest firmware (version 55), and now my wheel no longer works with either my PC or Xbox.
The Light just beside the Xbox icon does not illuminate anymore.
The Wheel will make slight 1 degree turns in each direction at about 1 second intervals, but does nothing else.
My Wheel has had a history of issues, more so after the warranty ran out.
None of the buttons on the wheel except the Xbox Home button works.

I was wondering if anyone else has had this issue before, and has a possible fix?
I’m on the verge of selling my +$900 worth of Thrustmaster add-ons and buying a Fanatec wheel, as in the past 2 years alone, I’ve sent my wheel back 3 times for a “replacement”, but the replacement wheel just seems to be more problematic.
Now my warranty has run out, I have no other choice then to either find a fix or get a new wheel.

Thanks for your time.

You should try the Bootloader Method. Full details here: http://ts.thrustmaster.com/download/accessories/Manuals/TXRW/TXRW_Bootloader_Method.pdf

Thanks for the reply.
I tried this and it did not work.
The wheel did not auto calibrate and no steering inputs where recognised.
The Light beside the Xbox Icon still doesn’t illuminate.

Any other possible solutions?

Go to the support page of the wheel from Thrustmaster and check if there is anything helpful under “FAQ” or “Knowledge base”:
https://support.thrustmaster.com/en/product/txracingwheelleather-en/

If nothing helps, try contacting the support:
https://support.thrustmaster.com/en/contact-en/