Unable to Launch Game

The same problem many other people are having, whenever I launch the game, the startup screen with the porsche appears for about a half of a second and then just goes away. No error or anything, and the game does not launch.

I have entered the powershell commands to refresh both the xbox apps and windows store.

My nvidia drivers and windows 10 are up to date.

My PC is a Republic of Gamers laptop G751 with a GT965m, i7. Well above recommended specs.

“Activation of app Microsoft.ApolloBaseGame_8wekyb3d8bbwe!forzamotorsport7 failed with error: The app didn’t start. See the Microsoft-Windows-TWinUI/Operational log for additional information.”

“The server Microsoft.ApolloBaseGame_1.107.1807.2_x64__8wekyb3d8bbwe!forzamotorsport7 did not register with DCOM within the required timeout.”

1 Like

Bump.

Would love to hear something on the source of this problem.

These are the error messages appearing in Microsoft-Windows-TWinUI/Operational log

“Activation via contract helper of the app Microsoft.ApolloBaseGame_8wekyb3d8bbwe!forzamotorsport7 for the Windows.Launch contract failed with Server execution failed.”

“Activation of the app Microsoft.ApolloBaseGame_8wekyb3d8bbwe!forzamotorsport7 for the Windows.Launch contract failed with error: The app didn’t start…”

“The app Microsoft.XboxApp_8wekyb3d8bbwe!Microsoft.XboxApp was activated for the Windows.Protocol contract successfully.”

The easy way : app troubleshooter

The hard way : security permissions
Important : backup your Windows first before doing these kind of things

Open up the command prompt as Administrator (really need Administrator mode for this) and type the following.

then open up the powershell as Administrator and type the following.

After a fresh install from earlier today my game would open.

Originally, my download was 95 GB, but it was interrupted by a windows store crash during the download. When it resumed the download was at 79GB. I assumed it had picked up where it left off, but I think that assumption was wrong. Today, I removed the game and began the download and again it started the download with 79GB remaining, even though i did not have the original data. After refreshing and restarting the windows store the download begain again at the proper 95GB and completed, and now I am able to launch the game.

While I am racing, the game runs fine (for a while), but it is obvious there are memory leaks. As I continue along my races, the game gets more and more laggy, after two or three races it will either be unplayably laggy, or it will crash, and I will boot back up into a smoothly functioning game. (for a while.)

Any time I am around the menus, whether I am customizing my car, looking at rims, buying performance parts, or whatever, the game ios VERY prone to crashing. I have crashed a dozen times in the last twenty minutes just trying to finish customization on one car.

Dumb fix that sorted this for me.

  1. Go to the windows store
  2. Download an app (ANY app, IDK do you like sudoku? ¯_(ツ)_/¯)
  3. Start Forza 7

I think this is a rights issue and downloading an app from the store causes Win 10 to check them and fix them.

i have this game nearly 1 month…when i first downloaded the game it did the same launch problem…i tried so many things you cant imagine and none o them worked…at the end i moved the game one my external hdd then it suprisingly worked…after that i moved the game back to the first installation directory my D drive it worked again…!
IN SHORT
==>i still get this WONT LAUNCH problem sometimes…whenever it happens the solution is this;

GO TO SETTINGS/APPS/FORZA MOTORSPORT7/ADVANCED OPTION/DELETE HONNIGAN CAR PACK…
START THE GAME and it wont launch as usual…
THEN GO TO MICROSOFT STORE DOWNLOAD HONNIGAN CAR PACK AGAIN…
START THE GAME and BINGO IT WORKS AGAIN xD

i beleive this is not a fault of turn10 but microsoft too…!
Honnigan is not a crime but OUR SAVIOUR…! LOL

1 Like

Open the windows store scroll up and down, click one or two random apps and go back…

I also tried it for a very long time and nothing fixed my problem. So I decided to call Microsoft Support and they suggested the following solution to this problem:

Close all the Microsoft-Store and Xbox-Applications (Not with the TaskManager) → search wsreset → Enter → wait untill the Microsoft Store has opened

If it still does not work, you should then download any free small app from the store (you can delete it later) to sync the accounts. Maybe you can also uninstall an app, but I’m not sure.

For me, it works fine and if the error appears again, I’ll just download an app again from the Microsoft Store.