Unable to launch game

I recently wanted to play the original Forza Horizon earlier this week but after started up my Xbox 360, the PLAY box (where it shows the current disc in the console) showed “OPEN TRAY” instead of the Horizon art. I opened the CD tray, closed it, and still not work. Also physically took the Horizon disc out and cleaned it, with no luck. Tried other games, which work. The disc is not scratched very heavily, but Forza 1, which is more scratched than my problematic Horizon disc, plays fine (aside from the obvious Original Xbox problems).

Can anyone help me with ideas to get my game to work? This is the first problem I’ve had with a game on any console, and this game worked FINE just 2 months ago.

Exact same problem here. I didn’t play for a while and now the disk won’t be recognized by my xbox. I even cleaned my drive and onboard memory (clear caches 3 times, erased profiles, format my drives), nothing works. After trying to buff the disk surface, without any success, I finally purchased another disk and ended up with the same result. I doubted it was my console, because every other game was working, so I asked guys at Microplay to test my to disks in their Xbox (s version, but I have the original one) : same result! Disk not recognized! I’m now thinking about a glitch with my xbox last update so I’ll try to update it again today. This is so frustrating…