Track disappearing in last race Seekers Cup

I recently purchased FM7 and installed it on my Xbox One X (within the last two weeks). After the (extremely large lol) download I started to play and have been enjoying it immensely. I’d say I get to do a race or two a night. However, I’ve recently had an issue that is affecting my ability to continue to play the game.

For my first set of races in career in the Seekers Cup, I chose the Rise of the Supercar series. Aside from assists the only adjustments I made were to play the races on Long (more laps). The last race of that series is at Circuit de Spa Francorchamps. The problem I’m having is that every time I try to do this race, about 3/4 of the way around the first lap, the track and objects start to disappear and I’m left with parts of the background, people sitting in invisible bleachers, some of the race barriers etc and the other vehicles. So much starts to disappear that I can’t see where I’m going to finish the race [on top of this just about guaranteeing I lose the series that I am currently sitting in second on… :frowning: ]

When I go to quit the race, the the loading/pit area is also mostly invisible. If I try to go to the menu, it sits there infinitely at a black screen with the loading icon spinning. Quitting the game hasn’t helped, hard resetting my xbox hasnt helped and neither has pulling the plug and letting my xbox sit. I’ve also deleted my saves and resynced with cloud to no avail. I’ve also tried the same course in Free Play at different times of day and all the same things happen.

This has left me with (in my mind) two or three depressing options, and I’m really hoping someone out there will tell me otherwise or offer up a different solution (please please please lol).

  1. erase my save game - least depressing as I haven’t been playing a really long time, but still, I’d rather not as I do have 10 to 15 hours in, and I don’t know if this would even help…
  2. erase the game and reinstall - not normally as big a deal as this, but holy hell it’s 100gb. My internet is just not that good. I had to bring my whole system some where else to install that patch and even then it took an entire night. I’m not sure when I’d be able to do that again, and honestly, I just bought this and shouldn’t have to. It will probably make me give up and just not play for a while until I get the time and energy to do that.
  3. return or resell - last resort obviously… I really don’t want to do this but if it doesn’t work in career and i only play single player, well, that doesn’t work for me, and I’m probably due a refund or exhange.

Any ideas?

TL;DR: My track is disappearing in races in career mode and stopping my series progression. It keeps happening at the same point and then I can’t get back to the menu. Has anyone encountered something similiar on X1X/X1 and had any luck fixing it without reinstalling the massive 100gb of game?

Try going into your xbox settings and clearing the cache
Can also completely shutdown the console and pull the power cable out from the wall

It is having problems reading the files for the assets of the track.
This will be down to reading the file from the disk, so either your disk is faulty at that point or that file is corrupt.
The only way to reset/test this is to uninstall the game and reinstall it (ideally cleanly in one go).
If that solves it, it was an install problem, if it doesnt then you may have a faulty One X with a faulty disk.

Since hard resetting, cache clearing, unplugging etc hadn’t helped, I decided to suck it up and do a fresh installation and update. Started last night around this time, and it just finished.

I was excited to go in and give it a try… except that now it’s just crashing at the splash screen. Splash stays up for
five seconds or so and then it dumps me to home. Just tried a hard reset and no change. This is really frustrating… I have no issues with any other games. My One X is only a few months old and Forza 7 I grabbed new about a week ago.