Thrustmaster TX 458 Italia accelerator pedal stopped working. Never mind, solved.

Hi All,

After picking up an Xbox one S with FH3 Hotwheels on black friday I’ve been enjoying my very first game console (used to be a PC gamer way back when). I had a hard time getting used to racing with a controller, so I recently pickup up a Playseat Challenge with a Thrustmaster TX Italia wheel and a copy of FM5.

I’ve used the wheel a bit in FH3 without issue, and yesterday I started the racing career in FM5. After fiddling with the controller options and updating the wheel to the latest firmware, I continued today. But after picking up after a short session today, my accelerator pedal stopped working.

I’ve tried switching of the Xbox completely in settings, and dis-, and re-connecting the wheel, but so far without result. All buttons work fine, brake pedal as well. The steering seems fine too when looking at telemetry in-game, but no accelerator pedal.

If anyone has tips for me, it would be greatly appreciated.


Never mind people, after hooking up the wheel to my PC it worked just fine. A case of RTFM revealed that in fiddling with the sensitivity settings, auto clutch and DOR I managed to set the wheel to clutch pedal mode. This apparently disables the accelerator pedal if you actually only have the stock brake and accelerator pedal. Would be nice if Thrustmaster included the MODE button and the corresponding flashing LED’s in the Manual, other then just how to switch to a different pedal setup.