Suddenly stopped working

I have been enjoying Forza 6 Apex on the PC immensely and I am looking forward to Horizon 3 but Apex was working just fine and now it’s not

When opening the game sometimes it crashes on the turn10 logo, or gets through to the menu but does not recognise my 360 controller (Which has always worked) or only recognises it for a few seconds. Then if i try using the menu with the keyboard it eventually just freezes and I have to CTRL-ALT-DEL to force close the game

I don’t understand it though because it WAS perfectly fine this has just happened suddenly and for no reason I can see

I uninstalled the app, then went back to the Windows Store and re-installed it. It came up with a windows to say it was downloading my content which worked okay but then crashed on the menu

Can anyone tell me what I can do to fix this or what to check (Is there a log file?)

PC Hardware:

Supermicro X8SAX
Intel Xeon W3540

I have made some progress with the issue but I am baffled by why it is happening or how to fix it. The crashing on loading screens and the controller stopping can be fixed by pressing alt-tab. The controller then works again for about 20 seconds. I have tried alt-enter to run full screen and windowed but it happens either way. It seems something is taking the games “focus”, but I have closed all background apps and have no notifications or pop ups


I dont have a direct answer.
My first suggestion would be however:

Download DDU

Boot into safe mode.
Run DDU and clean your display drivers and restart.

Reinstall you display drivers using the latest from your manufacturer (clean install)

DDU will also clean up any missing or hidden monitors/settings as well.

1 Like

I owe you a big thanks! DDU did not resolve the issue directly but it got be thinking about why you asked me to do it, specifically where you said “will also clean up any missing or hidden monitors/settings as well”

I always keep my drivers bang up to date, even stuff people sometimes don’t bother with like storage and chipset drivers. However, I had a look in device manager and low and behold “Generic PNP Monitor”. I have a 27" Samsung 3D Monitor, and therefore it has a pretty high refresh rate. Installed the official Samsung driver and the game now works perfect again. Still a bit baffled why it happened suddenly, maybe Nvidia 3d vision screwing things up or the last update for the game.

A big thankyou to you, I managed to finish my spotlights before they ended and pre-ordered Horizon 3 with confidence!

On that note, your result leads us to jump to another thread because that may solve their issue too.