[RESOLVED] Fanatec CSW V2 - No FFB Vibration / Surface Texture Effects [PC]

Hi Racers,

  • I have a Fanatec CSW V2 and am unable to feel any surface texture within Forza 7. I also have an XBOX 360 Controller with which I am able to feel varying surface textures spanning different hard surfaces to grass to curbs. With the controller I can vividly feel the moment the tyres start to slip, but with my wheel there is 0 sensation. It’s like Vibration is “muted” completely. I have tried the 2004 Impreza WRX STI and the 1992 Escort RS Cosworth Forza Edition at the Top Gear Test Track.
  • Didn’t take video
  • No error message.
  • Installed latest Geforce Driver. Installed latest Fanatec firmware for my CSW V2. Restarted my PC.
  • Fanatec CSW V2, Fanatec CSP V3, Fanatac Clubsport Handbrake
  • System Information

Operating System: Windows 10 Home 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)
Language: English (Regional Setting: English)
System Manufacturer: ASUS
System Model: All Series
BIOS: 3402
Processor: Intel(R) Core™ i7-5820K CPU @ 3.30GHz (12 CPUs), ~3.3GHz
Memory: 65536MB RAM
Available OS Memory: 65448MB RAM
Page File: 5091MB used, 70084MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
Using 2 MSI GTX 1080s in SLI

  • GeForce Game Ready Driver Version 385.69 Release Date 9/20/2017
  • Ultra quality

Any help / responses as to whether others are experiencing the same very much appreciated.

Thank you,


Had the same issue and fixed it via PS3 mode for my ancient 911 Turbo S wheel + ClubSport v1. See here fanatec tip

Thanks a bunch AndyPandy. Unfortunately no dice. Not sure if it’s the new Firmware or what, but once I went into PS3 mode the Fanatec Driver register the CSW as the Logitech G27 as it should have, but Forza would not register any inputs whatsoever. Darn. Looks like I’m calling for official tech support.

It’s the oddest thing - I can feel the wheel center w/ spring / damping forces, but 0 vibration. No feel of surface, no feel of slip. I also just discovered there are no collision effects - I gunned it into a tire wall and nothing.

Did you try uninstall the fanatec drivers and than use the default Win10 G27 or install the logitech drivers? For me i can actually start the game by pressing X in PS3 mode and navigate the menus using the cross, which never worked in the default PC Mode using the fanatec drivers and setup as custom wheel.

Hi All,

Hopefully this helps at least one person avoid this issue and slight shame of having had the issue in the first place. I’ve been using Fanatec devices for years, so can’t believe I did this.

When you install a Fanatec driver, at least for the CSW bases, the driver will automatically update your Firmware periodically. I mistook that firmware update for also being a driver update - not so, and obviously there is a clear distinction between the two.

Go to Fanatec’s site, download the latest driver for your device - the driver will periodically update the firmware, but the driver itself must be updated by the user - ie. DLd from the Fanatec site. Once I did that, Forza’s FFB system worked a beaut.

For any Fanatec noobs who read this, record your wheel’s S_1 - S_5 settings before updating firmware as they will be wiped.

Thank you community member AndyPandy2244 - while I didn’t ultimately use your suggested fix , it was the “Did you try uninstalling the fanatec drivers…” which gave me that “Ah-Ha” / “Oh S***” moment that did resolve my issue. Big thanks.