Ranked adventure group (Team) queue bug

So for ranked adventure, if queuing as a group we would find that the leader gets the queue pop but the convoy members do not. This causes the players in the convoy to get left out of the match, giving them up to a 30-minute ban. The leader isn’t impacted by this.
This is made worse by the fact you can join someone’s convoy that is queueing causing them to drop out of the queue and get a ban. My last was 30 minutes and unintentional by the other person but this could be used to grief friends. This seems like a bit of an oversight but okay I get that

Here is what we found:
We tried queuing as a convoy and as a team in a convoy, restarting the game between each try. - Still, get banned
We tried different leaders in the convoy which still only pops the queue for the leader and they get in but the convoy members do not. - Still, someone gets banned
XBOX app shows all green in the network tab. - Issue still persists

Any ideas on what to try next would be great, we are stuck and cannot do any team ranked adventure.