random texture "neon" corruption.

I am getting this random neon-blocks texture corruption on pc with the latest version , on amd rx vega 64 with 17.11.1 crimson drivers.

I do as well, seems to be due to the drivers from AMD though, Forza Horizon 3 takes about 5 minutes of initial load time as well.

Try to revert to 17.10.1 or earlier to get a relief, although I would prefer an answer by someone official.

I’m using 17.11.3 and have same issue with both Forza 7 and Forza 3 Horizon. Also running a RX Vega 64 liquid cooled card. I wonder if this is just a problem on the Vega cards, someone on the Forza 7 forums also reported same issue with Vega 64.

I don’t have this issue with my RX-470, and I just updated to 17.11.2 the other day… so I guess I won’t move to 17.11.3 yet…

There’s another similar post from another Vega user. So either it’s specific to that line of cards or the recent driver updates are mucking things up quite a bit. Is it more common at night or in the rain? Overclocking is also suggested to be avoided, or at least any software OC control. Personally, only my processor is OC’d, but through BIOS, and I have no issues.

Ok for Vega users this is a known issue I guess, just read it in that thread. See fix, I did this and it works fine, just turn on the HBCC setting go to AMD Radeon Settings control panel then Gaming → Global Settings and turn on HBCC by checking the box, set the RAM setting all the way to the left (lowest amount) you can use more if you want of course just keep in mind how much overall system RAM you have. I verified this fixed the issue for me in both Forza 7 and Forza 3 Horizon with 17.11.3 hotfix drivers for Vega cards.

PC SPECIFIC KNOWN ISSUES
• Players using AMD Vega hardware may experience graphics not loading properly on the track when racing. We suggest enabling the HBCC Memory Segment by opening the AMD Radeon Settings app and going to the Gaming tab → Global settings and clicking the “HBCC Memory Segment” option. Make sure the slider next to the setting is set all the way to the left. Players may also see the screen go black or see flickering for 1 minute after turning on the setting.

Full known issues thread here, its at the top Forza Motorsport 7 Known Issues [PC/Xbox] - Community Support - Forza Motorsport Forums