[PC] CRASH - game crashes 2 seconds after start [PC]

So I press play and it goes by 2 seconds and the game shuts down.

NOTHING in the following article have worked for anyone with this problem; https://support.forzamotorsport.net/hc/en-us/articles/360007593074-My-Game-is-Not-Launching-on-PC

So now that that article isn’t helping I am wondering what the devs next step is? How do I fix this?

I got exactly the same issue.
I tried also all methods, nothing works…


same problem, but i playing complete 2 race and my game close and now i cant run it

In my case, the problem was MSI AfterBurner (or more precisely, RTSS, that can show in-game overlays): I must close it in order to launch the game.

Your case might be a similar application.

Corsair’s iCUE and Team Viewer can also cause this, as well as any other application that injects something into game’s process.

Same issue here… it closes after a few seconds. I have RTSS and iCue off and nothing is helping…

Same problem, even after closing RTSS and MSI Afterburner the game won’t start.


GG Microsoft.

This happened last time with Horizon 3. Nothing is working, not sure why the demo worked perfectly fine and the full game just doesn’t even start. I hope it gets solved within the next hour.

1 Like

Thats what I dont understand… The demo worked flawlessly. Now the full game doesnt?! Seriously thinking of refunding this.

Yeah, the demo worked perfectly fine, even with RTSS. Now people are saying that the game does not even work with MSI Afterburner, yet the stupid demo did. Is this serioulsy the talent behind the game developers? I even started the demo with a dated nVidia driver, it did crash but once I updated it it started without any problems.

Closing Afterburner does not help at all, game still crashes; not that I find fun in closing the tool I use to measure my PC performance and to lock my frame rates. I had a feeling MS would screw up somehow. And so they did.

1 Like

yer got the same thing opens then crashes after a couple seconds

same problem, but demo work perfectly

Same here. I remember having this issue in FH3, but I don’t remember how I solved it. FH4 demo was running fine. Tried everything but reinstalling the game (as it takes hours to do…) I’ll try that when I go to sleep.

Same for me too. When I click the fh3 icon the splash screen opens like its going to launch, then boom, closes and nothing happens. Upon checking in “manage” via the windows store all sorts of fh4 stuff is installed like fm4 itself, vip, car packs etc but fm7 ultimate edition says “install”…however upon clicking on install it basically just sits there forever saying it’s ‘working’.

Demo ran fine, launched the full game tonight, ran fine for 2 and a half hours. I closed it. Went to re-open it a few minutes later, crash on splash screen. Tried all the fixes they suggest, rebooted, ran wsreset, logged in and out of the store, everything short of a reinstall. Nothing has worked…

[Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D]

This is kinda rediculous. I’ve tried so many things to fix this. Exited every app/tool i can find. Ran WSRESET and restarted. Created a new profile, logged back in. Downloaded a free app from the store.

Nothing seems to work. I had issues years ago when downloading FH3, but once it downloaded it worked fine. I played it a few weeks back and it was fine. Played the FH4 demo and it was fine. Get full game and 2 seconds of the loading screen, then nothing. No error, no nothing. The fact that so many people have this baffles me. Steam works fine. Origin works fine. Uplay works fine. Why can’t this work?

1 Like

Good to know I’m not the only one with this problem, same thing happens after trying the same support website. I remember FH3 also having this problem for a while but it was easy to fix/workaround. Hopefully it’s resolved soon, in the meantime I guess it’s back to enjoying the Toyota’s, Mitsubishi’s and Lexus’ again

1 Like

I found a temporaly fix, in my case update nvidia drivers to 411 , when i play forza show logo, dissapear and crash,ok, simply close msi afterburner an riva, when the game launchs and show the turn 10 logo initiate msi again and its worsk, OSD no work

I had this exact problem as well, until I shut off EVGA Precision X. Then it launched without issues.
But as soon as I turn Precision X back on the game crashes.
Seems to be linked to hardware monitoring software, in my case atleast.

The weird thing is the first time I booted the game up, Precision X was fine, even with my OC. Once I closed the game out and restarted it again, that’s when these constant crashes started happening. Very weird, The demo worked fine with it too and apparently the first launch.

Having the same issue. First time I boot it up it did fine. Ran a benchmark or two and changed some graphic settings. (These were all working since I benchmarked them all.).

I restarted the game and BAM…now all of a sudden the game closes immediately after startup. Event Viewer keeps showing Exception code: 0xc0000005 and Event Name: MoAppCrash. Event ID 1001.

What a bummer, was hyped to play this and now all these issues. This is why I hate the Windows Store.