PC Controller acting up.

Every time I press a button on my controller, when I release it it jumps right back to keyboard input so the game is just impossible to play. It works perfect in Horizon 3.

So any ideas how to fix this? Or is it the game?

1 Like

I have a problem too, seems that i the sliders in the advanced input settings dont work, they are stuck at 0 and there is no way i can change them. The cars drive horribly. Anyone got a fix?

We already have a thread of this happening. Hopefully get’s solved. I assume its same as my problem with an xbox one controller that worked perfect for the Forza 7 demo

yes thats exactly the problem i have, hope there is a fix soon

Same as me. This is unplayable. I hope they will fix it or find a solution.

I fixed my issue. I unplugged a powered USB hub that I had a x52 pro hooked up to. How many controllers do you have active? I had rudder pedals, flights tick, hotas, yoke and my Xbox one controller. Now I’m good

only controller and my headset

I have only headphones and controller, and i have the same problem…

I have the same problem. Only USB devices I have are mouse, keyboard and Xbox one controller. Works great in FH3.

The solution I found is to check for Windows Updates and Your graphics card drivers. This helped me,