Once again, a new expansion completely broke my game. Is this how Turn 10 treat its players?

Hey all. This my first thread on Forza Horizon 3 official forums (and first rant).

What i’m really shocked is how the devs have still not fixed this issue ever since Blizzard Mountain has been released.

Firstly i have to note that this issue is pretty rare… a very small portion of players have faced this issue (i’ve chatted this with others on gamefaqs about the issue a while back). I also don’t go the these official forums as much either.

I also should note that i own the physical copy if that matters.

So what’s the issue? Here how it goes and it’s a simple bug.

Every time when a new expansion releases, it shows the new trailer once you leave the festival.

After the trailer ad, it obviously asks if you want to “buy now” the expansion. When i click no or (B), guess what? NOTHING HAPPENS! It won’t send me back to the game, festival, or anything. This makes the game unable to race basically… just only play on the festival menus. But it obviously works when you click “buy now”. How silly…

NOTE: I also know how to fix the issue too which is kinda of a hassle. You need to use The Forza Hub app for it to play the game again.

Even though I know how to fix the issue, it’s still pretty shocking how the devs still haven’t fixed the issue ever since Blizzard Mountain was released. This made me unable to play Forza for A WEEK until someone on gamefaqs told me how to.

Why is that Turn 10? Do you ask your customers any feedback? Because from what i’ve heard from many fans and players, you guys don’t provide any questions/concerns which is pretty disappointing (again i don’t go the official forums as much) But i feel that i have to share this when the devs and you guys. This is just unbelievable!

Here’s even a message from a fan too (this is a reply from the thread i’ve made about the issue).

“A lot of people have complained about their lack of communication but they obviously don’t care. They can’t even give us patch notes when they change something”.

I also have a feeling that there’s every small portion of players who are unable to play this game because of this issue… or still haven’t fixed it since Blizzard mountain came out.

So to the devs, are you guys aware of this issue? Again… this has been an issue since Blizzard mountain got released.

To the players, is this really how Turn 10 is? Do they provide any player feedbacks or concerns? AGAIN, i don’t visit the official forums as much either. I’m already seeing a lot of locked threads of players having issues with the Hot Wheels expansion too. Hopefully i got a response from you guys. And Hopefully, this thread doesn’t get locked because some devs just can’t handle the… truth? Hate? Criticism?

Sorry for the long book but this I felt that i HAD to share this with the official forums. This is just unbelievable.

1 Like

My son is having the same issue see the hw intro then can’t click the b button to go back. I tried the hub thing not working. Can anyone please explain in detail how to fix the issue without buying hw expansion pack as he just wants to play his game. Thank you

This can’t be…

I also tried the Forza Hub thing and it actually doesn’t work… unless we did it wrong?

If we did it right, the game is completely unplayable sadly.

I’ll try to notify you if i figured out a way (unless i give up and just buy the new expansion which most likely i won’t).

Both of you, try doing a full hard reset of your consoles:

http://forums.forzamotorsport.net/turn10_postsm528894_Losing-saves---What-can-I-do-to-prevent-it.aspx#post_528894

IF you didn’t receive and install the Content Update, which was released Tuesday at 10 a.m. Pacific Daylight Time, that could be the issue, too.

Once you do the hard reset - and do NOT skip any steps - check your game (Manage game from the dashboard) and make sure you’ve got all items installed which should be before attempting to start the game. If it is syncing, do not interrupt or quit out of that. Only play the game once all items have been properly installed, and NOT when it says “Ready to play.”

4 Likes

Thanks for the help but none of this works…

I hard reset my Xbox everyday btw. I always do this to avoid any internet disconnections or any game issues

Also, this issue occurred right after i fully updated the game too. It’s on its latest update.

So yea… the game is unplayable… great!

I guess i’ll stop playing the game for now. Not gonna buy the expansion until it’s discounted. Sorry for sounding cheap… but this is coming from a budget college student.

If anybody reads this (or the devs), please help us. If i don’t get any help for a week since this thread was created, i’ll just uninstall the game entirely.

BTW, for those that will say to uninstall the game and download it again, it still doesn’t work either. Tried that twice on Blizzard Mountain and it didn’t work sadly.

My son is having the Same issue. it also happened with the blizzard Mnt. expac so we got it for him for Christmas. Unplayable what the Heck is up with this [Mod Edit - profanity and abbreviated profanity are prohibited by forum rules - MM]

If you’re having a support issue, it’s best to report it in the appropriate Support forum for your platform. Here’s a Turn 10 team member addressing an issue with the Blizzard Mountain DLC and asking for feedback:

When providing feedback also include which DLC you own.

1 Like

Hey all again.

I finally got the game working again! YAAAAAAAAAAAAAYYYYYYYYYYYYYYYY! WOOOOOOOOOOOOOOOO!

As i tried many times, i did use the forza hub app here are the details.

This works as workaround:

1 - Load up Forza Horizon 3 and get to the “Buy Now” screen you are stuck at.
2 - Use the Xbox Guide button to go back to the dash and open up the Forza Hub App. Please don’t shut the game down
3 - Open up the Blizzard Mountain is Here! Story on the Forza Hub App.
4 - Press the black “Play Now” button on the first page of the story and then press continue when prompted
5 - Go back to the game and you should now be able to back out of the “Buy Now” screen

Hope there is a permanent fix for this soon, im experiencing the same issue and have already cleared my system cache, removed and added profile w/o success.

I wish best to all and hopefully Turn 10 will not ignore this and fix it. If it doesn’t work, keep on trying it.

Where is the Blizzard Mountain. If you mean the hot wheels, there is no black play now button. How do you do it?

You’ll need to scroll through the articles to find the one about Blizzard Mountain.

I have the same problem. When I tried the Forza Hub, there was no button to go to forza. Any fixes?