No credits

I ran 35 laps at nurburgring. After finishing race i quit out. It showed me taking first place. After i hit continue. It returned to the main menu. I thought that was weird. So i then ran 2 one lap races. At the end of those races i recieved 17,000 credits. So i ran a 10 lap race. Once again at the end no credits. I ran that track for 4 hours with nothing to show for it. What’s the deal? Xbox one

Either using a rental or
Using super easy assists
That would explain it

Well i didn’t use a rental nor did i have it on super easy. I thought super might have made a difference. Thats why i ran two one lap races. I ran one on hated and the other on easy and recieved credits for both races. So that wasn’t it.

Super easy seems to only affect races more than 1 lap

oh… what about if you change difficulty during the middle of race? I think that what could’ve happen. I noticed after i started the race that i had no control. I didn’t start race over. I paused it and change my assist

That’s quite possible
Hopefully for some it will get fixed
Did you do it after todays update

No i haven’t tried it after update. After driving for 4 hours with no credits. I gave up