Neverending audio problem "stuttering" - my solution

Hi I want to share what I discovered. I suffered with sound stuttering for a long time in FH4. Try every possible solution I can found on net, nothing helps.

Then just for fun I overclock a little bit my CPU. I dont think overclocking itself helped (4Ghz to 4.3Ghz). But what a I think helped was turning off in BIOS all “amazing stuff” like Turbo and AMD cool and quiet and so. What I think that happend: These settings that I turn off adaptivly changes frequency of processor and it seems FH4 (and also HALO) somehow dont like this.

The change was imminent. So far after pressing start button I have to wait about 2 minutes before FH4 starts. Now its 2 seconds. Sound sttutering and FPS drops are gone. I am playing on ULTRA settings in 4k.

I am not familiar with new names of “amazing” technologies, but my advice is to turn all them off and force CPU to stay on stable frequency.

My old (except for GPU) PC specs: AMD FX-8370, MB MSI MS-7699, 32 GB RAM DDR3 1600Hz, GTX 1080

I hope this will help somebody…