Multiplayer has temporarily been Disabled for over a week now ?

Hi guys

As title suggests I can’t access forza motorsport 7 multiplayer all it says is Multiplayer has been temporarily disabled. I’ve not been Banned as there’s no messages and my internet works fine I’ve checked my Nat type is open etc. Have super fast internet connnection too. Noticed it’s just for this game though really frustrating as I don’t know why this has happened. Hopefully it can get resolved.

Cheers Chris

Been working fine for me.

Hard rest your router/modem/Xbox blah blah blah if you haven’t already.

I’ve tried that and still no luck. Hard reset Xbox too. It’s not a Router problem as I’ve tried a New one and it made no difference .

Everyone should reboot their routers now anyway cause of RU botnet.

Can a Moderator help me please this is a really frustrating issue if I have been Banned I’d like to know I rarely go on this game maybe once or twice a month and race clean. I also haven’t received a message stating that I have been banned.

Could be your ISP pushed a firmware update to the modem that’s the problem. Had that happen a few years back with Comcast and spent weeks of my free time trying to figure it out. Finally after testing everything and hours of phone conversations with comcast and xbox support I decided to call comcast again. I told them everything I tried and let them know I was not your average everyday idiot and asked if they had done a firmware update in the last 4 weeks. He said yes they did and the only option was to get a different model modem and see if that works and thankfully it worked and I’ve never had a problem again.