Multi-input mapping = No steering input on T300RS

Playing on Windows 10 Pro - V1809

So, I have a T300RS as my wheel, with my pedals running though it. G27 Shifter & buttons with analog “hydro” e-brake running though an unpowered G27.

Now, individually it all works perfectly fine. I use it near daily in Assetto Corsa but no so well in FH4.

If I tell the game to just use the inbuilt preset for the T300RS, I get

  • steering/FFB
  • wheel buttons
  • paddle shifts
  • the 2 buttons on the lower right of the base
    and 3 pedals all working perfectly.

If I go into a custom mapping, I can map everything and the game sees it and everything appears to be fine.
I get

  • 3 pedals
  • paddle shifts
  • wheel buttons
  • the 2 buttons on the base
  • H pattern shifter
  • shifter dpad/ABXY/4 red buttons
  • handbrake analogue axis
    but no steering and but extension of course, no FFB.

This happens with combined steering, so I tried to turn combined off, turn the wheel left of center, map steer left, then turn the wheel right of center and map steer right, which seemed like it was going to work but even after saving it, no steering still. Upon going back into the settings it’s set back to combined steering anyway.

I tried to map steer left to the wheel axis and steer right to the “hydro” e brake axis but it still comes back up as combined steering with nothing mapped to the steering axis when I go back in to the settings.

Initially figured that it was a clash with my controller so I unplugged it, rebooted PC and tried again. Settings still show steering is mapped to Device 1 : Axis 1, same as the T300RS preset but nothing happens in game still.

Then figured it was a clash with steering axis of the G27, but with no power there is no position tracking for it, confirmed by the “Set up USB game controllers” window in the control panel. Moving the wheel does nothing to any axis or buttons. so it’s not that either.

Guessing it’s just a bug because the steering itself does work for the preset and the mapped axis is the same on the preset for T300RS and my custom mapping. Been chasing it on and off since multi device mapping was made live, but never found a workaround or cared enough to make a post but I’d love to slam some gears around FH4 with a wheel.

T300RS Preset
T300RS Preset

Custom Mapping Device 1 Axis 1 Combined Steering but no steering in game
Custom Map, Combined steering but no steering in game

Custom Map, Separate steering, but wont save. No idea if it'd even work.
Custom Map, Separate steering but wont save so no sure if it’d work.