Manual Gears Not Working Since Update

My X button to go down a gear has been removed from the controller by the Update. I can’t re-assign it either as it is used to go into a house etc. Usually Manual gear will allow you to use X to go down a gear as default.

Anyone else having this problem?

Have you tried switching it to Automatic, then switching it back? I’ll check it out if I can make it home from work in the morning.

Yes I switched it on/off, but still doesn’t work.

OK I’ve figure out what the bug is.

I swapped the horn to Y
I swapped Rewind to Right/Horn button

Because I use the horn, but never use rewinds.

Saving that broke Gear Down.

The game doesn’t let me fix it, because manual gears has no map assigned. Map assign is supposed to be none assigned. The game is asking me to assign the map when it is supposed to be none assigned.

That’s a bug.

Ah, that would explain why there was no problem with my settings when I checked today, as I haven’t modified the mapping. Usually there’s a reset to default option, which should fix this sort of thing (that really shouldn’t be a problem in the first place).