leviathan Achievement is bugged/glitched

I’ve tried everything I can think of.
I’m using the correct car.
I ran a 2 lap leviathan event. NOT a custom route
My Time was high 15 min 50 seconds.
Didn’t pop the leviathan Achievement

I then ran a 3 lap leviathan event, again NOT a custom route
My time was in the 23 min range.
Didn’t pop the leviathan Achievement.

I ran the leviathan that shows when you hit the event.
1 lap, night and in the wet.

Times listed as I finished 1st.
Best lap: 7.55.042
Time: 7.59.0513

Again it didn’t pop the leviathan Achievement.

I restarted the Xbox, nothing.
I reset the Xbox, Nothing.

Could you explain to me what I’m doing wrong?
I believe there is an issue with this leviathan Achievement.


Just got home from the day job gig.
Turned on the Ol’ Xbox, signed in and
Boom… Leviathan Achievement popped… finally…

Don’t know what the issue was…

I ran a couple of leviathan events yesterday.
2 or 3, 2 lappers and a couple of one lappers.

Did pretty good I thought, I got under the 8 mins once or twice.
The leviathan Achievement didn’t pop though…

Anyway, That’s done…