[INVESTIGATING] DS4 controller not working.

Using a DS4 Gen2 controller on USB 3.0 wired connection.
Controller and all buttons are recognized by Windows using the native Windows drivers.
Controller works in all other titles like Dirt Rally and Wreckfest.

Does not work in Forza Horizon 4 natively.

Installed DS4 Windows - now the controller input is recognized by the control screen without issue.
However, in game inputs are completely off -unplayable. Vehicle response stutters when trying to do anything (accelerate, brake, turn, etc)
Accelerating using “R2” and even the “X” button, the cars RPMs are jumping all over the board.
Turning is near impossible as it’s only recognizing maybe 20% of the polling data (doesn’t matter if configured to LS or D-Pad)

Please fix.


i have the same problem

I get this as well with DS4Windows and a wired DS4 controller. Expect the issue is DS4Windows, not FH4, as DS4Windows just mimics the contorller as a 360 controller and my 360 controller works fine.

Horizon 3 doesn’t support DS4 natively though so i doubt FH4 ever will unfortunately :frowning:

1 Like

I’m using Magic-NS adapter for DS4 and it works without a problem with FH4.

Try going on the DS4 Windows → settings → check “hide ds4 controller”

that worked for me in both fh3 and fh4 demo


I tried turning this option on, yet it says that it was unable to hide the controller and I’m still expiriencing this issue, anyone knows a fix to this?

This worked for me, sometimes if other programs are open it would not work but when all are closed seemed to be perfect thanks.

If you want your gamepad to work with DS4 Windows, you need to switch ON Hide DS4 Controller in Settings tab while in game. It works for me.

1 Like

How do u turn on the Hide DS4 Controller option? It doesn’t work for me. anybody knows a fix?

Also having problems here using the DS4 controller. I’ll try using the hide controller option, but I honestly think it won’t help. Here, the controller works with every single other game, and it’s detected as an X360 controller, even forza horizon 3 works, but not horizon 4. I tried even using my old xbox 360 controller that’s compeltely meses up, but for the 3 minutes that it worked, it worked perfectly, I was able to move around the menus and drive normally. The problem I have with DS4 is that the only thing that works on menus is the analog, I can’t enter or exit any menu, and in game, the controller randomly stop accelerating, steering and braking. The most insane thing is that, whenever I try using the DS4 controlelr emulated as an X360 controller, the loading screens show a wheel button map even if my wheel isn’t plugged in the PC! (By the way, I find it insane that DS4 controller don’t work and my wheel work in this demo)
UPDATE: No, turning on the “hide controller” option makes no difference, it still doesn’t work in forza horizon 4.

1 Like

I had exactly the same problem as you, my ds4 worked in horizon 3 and every other game, but not fh4. i also didn’t get it working by checking hide ds4 controller. however if i shut down all apps on my system, steam, uplay and lastly microsoft store (the store was the last one i had to shut down before the problem got solved, even though i thought this one would not matter) and then checked the hide ds4 controller option and started the apps and fh4 again. it now worked. apparantly the ds4 controller can’t be properly hidden with other apps still running.

Doesn’t help. I even opened up task manager and closed every app that could’ve mattered to stopping this, yet still the ‘hide ds4’ option didn’t work properly - telling me to close all of those apps that weren’t working from the start. I hope they will find a fix for this, because honestly this game seems great, and it would deeply hurt if the only thing stopping me from playing it would be the controller not working properly.

1 Like

I’ve experianced the same issue. The problem with the ‘Hide Controller’ setting is that for some reason it never works, saying there are a few other programs running in the background, while none are running. From what that I checked I can say that this issue has been known about for a long time, and yet nobody found a pure fix to turn on the ‘hide controller’ setting. I hope that forza do some changes so that you’ll be able to use the ds4 on the game, like they did in fh3, cuz I don’t have an xbox controller and the game runs perfectly enough for me on my pc, so the only thing limiting me right now from buying the game is the ds4 not working.

1 Like
  • Launch the game, wait for start menu.
  • Alt+Tab to desktop
  • Launch DS4 Windows
  • Check is the gamepad buttons works?
  • Go to Settings tab
  • Select Hide DS4 Controller (if asked select Yes)
  • Check in Control Panel > Devices and Printers, there should be only Xbox360 Controller (no wireless gamepad etc.)
  • Back to the game
  • Play with DS4

It works for me everytime I do this.

The hide option never works and never worked. I tried everything, even closing every single other program and then turning it on, it does nothing, It changes nothing


An update for anyone that still has problem with it: I managed to make it work! I did lots of things, so I’m not EXACTLY sure what I did to make it work, but I’ll say what I THINK was the solution: if even after you close anything like steam, uplay etc and DS4 still says it can’t hide the controller, try turning off NVidia overlay. For some reason, that was (probably) causing the problem to me: I closed steam and etc, stopped the program, disabled NVidia overlay and turned it on again, and now it works like a charm! I think the only problem is really NVidia overlay.

1 Like
  • Close Steam/Uplay
  • Launch DS4 Windows as Administrator
  • Make sure the controller is connected and it says Start in the bottom right corner
  • Go to device manager from Windows and Disable HID-compliant game controller
  • Go to settings in DS4Windows and tick Hide DS4 Controller (If this option is already ticked untick it before trying this method)
  • Go back to Device Manager and Enable HID-compliant game controller
  • In DS4Windows click the Start option in the bottom right corner and it should work
    (If it doesn’t work the first time keep trying or restart your PC and try again)

I tried all this troubleshoot like:
Hide Ds4 Controller in ds4 settings
Disable Nvidia In-game overlay
Closed all apps like steam/uplay/ms store etc.
Don’t start ds4 before starting the game
The solution he tried to provide in the quote.

NONE of this actually worked… None of this…

What I’ve figured out is that the fault here is either the controller, or game isn’t fully using the controller’s right trigger, yes everything was working except when I accelerate, the car wasn’t fully accelerating, not using enough rpm and I found that if I use my middle finger at the top of the right trigger(R2), I was accelerating like not fully but I was using a bit of rpm than before, like before holding the R2 trigger with my middle at top slightly, I would accelerate at speed like 72 mph, by holding I was speeding at 110 mph and that’s the max speed I was using…

So the conclusion from all that, I can assume it’s either the ds4 controller is faulty because the right trigger isn’t using enough power or the game isn’t fully using R2, but I wouldn’t blame it on the controller because I play other games on my pc that uses R2 trigger and works fully functionally… Such a shame that this game is soo amazing and runs really good on my pc and I can’t play it now without a Xbox 360/one controller…

Just wondering if there’s any confirmation if we’ll get DS4 native support when the game comes out, because DS4windows was always buggy for me.

So I wanted to use my PS4 controller on the new demo and it barely works. The 4 buttons Square, Triangle, Cross, and Circle only sometimes register and usually never work. I Have to spam the buttons then sometimes I will get an input. The Dpad works fine but the thumb sticks sometimes work but won’t move or have an input when trying to steer it would work sometimes but usually never. The triggers have an input but then will just stop and then go again and its uncontrollable. I can be driving holding the throttle all the way down then my car will slow down as I I let go for a bit. The bumbers don’t work at all and have no input so i cant even change a view or other uses. The share and options don’t work either so I cant go to the options with the controller.

I have used almost every program that is out there and still have the same problem or it doesn’t work in general.

Input Mapper
DS4 Windows
Even adding the game to Steam library
Ticking Hide DS4 box in DS4 Windows
Restarting my PC and trying again

I hope it won’t be like this in the full game someone have a fix?

I have found a fix the hide DS4 does work you just also have to disable the NVIDIA Overlay and then it should work that is what I did then i started up thew demo and the controller works fine.