Input/Steering lag on Series X

This was always a buzzkill in FH4 and seems to have stuck around in FH5. The issue is non-existent in FM7. I feel it with Xbox gamepad, wired or wireless, as well as with Logitech G920.

This isn’t a latency issue, tv and console are in perfect sync with each other, typically around 17-19ms. No, this is definitely a hard-coded input lag that I do not experience anywhere else but Horizon.

Very frustrating and makes driving no fun at all.

(But otherwise I’m really enjoying FH5)

1 Like

H4 was much faster so I don’t think you are right.

Didn’t have any issue with FH4 on Series X but can clearly feel an input lag on FH5 now. Anyone else ?

1 Like

Make sure you go into your settings and lower the deadzone on the steering. It’s set to 10 by default. You’d need some pretty bad stick drift (like a few months old elite controller, lol…) to need to use 10…

Already done for gamepad and the wheel settings are adjusted as well. There’s just massive lag between controller input and vehicle movement. It’s infuriating because I can play FM7 and it feels great.

And the previous poster is right, FH4 is faster BUT it still feels “heavy” compared to Motorsport 7. I’m really hoping to see this addressed by devs because it truly ruins an otherwise excellent racing experience. (For me, at least, and I certainly can’t be the only one bothered by it.)

Might not work but definitely worth a shot if anyone of you having similar issues uses steam.

My issue was laggy input that had a hint of randomness. Sometimes the steering was small, nonexistent or sometimes there was a lot of steering input. It was impossible for me to do small corrections to accurately approach the braking area or stabilize the car after the corner usually leading to a crash.

In steam, go to

  1. Steam → Settings → Controller → General controller settings
  2. Disable xbox expanded feature support
  3. Restart your PC

What worked for me on a G920 is turning off Combined Steering. You’ll need to set the right steering on axis 1 as well after that. No input lag at all for me now.