I'm in big trouble

Hey guys.

I have a bit of a problem. A few days ago I had to reset my router due to some connectivity problems.

Now, as I launched FH 4 today it worked fine first but it didn’t want to connect to online lobbies. So I’ve exited the game and unlocked the required TCP/UDP ports and enabled Teredo passthrough in my router settings.

After this I’ve launched FH 4 again and got greeted with the following error message.

I know this doesn’t look good, but I have a laptop with the game installed with a quite older (working) savefile on it. Since the current file from my PC seems to be broken, I could try to sync the game with the older save file from my notebook. But I’m afraid if I launch the game on it, it may try to load the broken save file on it as well.

So what should I do?

Not sure if that’s the similar thing that happened to me, where I got just unknown error on sync. Resetting the game in apps and doing the sync, fixed it.
In any case I’d do backup of local save folder.

My theory on how to get old save uploaded is (don’t hold me to this, its just what I’ve seen so far from my game behaveiour) - this would absolutely be last ditch effort.

  • have old save ready (zip, etc)
  • start sync, but interrupt it (disconnect network)
  • shut down the game
  • replace save game folder
  • start the game and hope it asks you, which save game to use (cloud or local) and use local
  • hope it works and it upps working save

Where do I find the save file?

I make 7zip archives of the folder and copy it somewhere, because if you reset the game, “microsoft.sunrise …” folder and anything in it gets deleted too (along with your backup file, if you had it in there).

1 Like

I had the same problem with my secondary account three days ago but unfortunately I had only a very old backup (6 series ago).
There is not any manner to recover your save and what you have to do is firstly to backup your old precius backup, then cancel the local broken save and copy in the same place the old backup save.
Start the game and don’t let to finish the sync, The game tells you that in this manner you have only an incomplete save, accept and play with the old save then exit and don’t switchoff the pc or console, you have to give to the game the time to upload the old save in cloud.
That’s all

2 Likes

Thank you for the info, I overcomplicated things.

I think I’m lucky.

Seems like all I needed to do is deleting the local save on pc and let the game replace it with the one from the cloud. And game seems to be all fine for now with online lobbies working.

I think it’s to early too say it’s all good, I still need to keep an eye on it.

But this shows how important it is to backup your saves on your hard drive, just in case, because things can go bad quickly.

Anyway, thanks a lot El Barto inc and Salfox69 for the quick help.

Great that you got it fixed :slight_smile:
I do my backups every week, after completing the playlist.

On side note, watching my WiFi traffic and game sync. Game/windows starts upload/sync of the save, after 15 or so sec, after you exit the game.
So I wouldn’t recommend to anyone, immediately shutting down the PC, after exiting the game.

Edit
Maybe this thread could be merged with one mentioned in my previous post, about loosing savegame, as here is at least PC solution?

How long does it take to complete the sync?

I was starting to think something like that must be happening. I only play FH4 on one PC, so have never had a problem, as presumably if it hasn’t synced with the cloud, it doesn’t matter, it just uses the local save. But I have AoE II DE on two PCs, and have had sync issues there. It seems to be some sort of Xbox Live sync tech that is the same in AoE II DE as FH4. One of the PCs I run it on is on all the time, but the other one is a dedicated gaming PC, and I will generally shut that down as soon as I exit the game I was playing. What has been happening is that when I then run the game on my “always on” PC it complains the other PC hasn’t finished syncing yet, even though I last used it a day ago, say. So I had thought there must be some sort of delayed sync going on as you describe, that wasn’t happening because I was shutting the PC down too soon after exiting the game. It really ought to show a dialog on the screen to tell the user it is syncing and telling them to not power off the device until it has finished.

On my “super quick 10/1Mbps” internet, it takes about 30 sec to 1 min, to complete the upload (that is 1Mbps - 125kB/s up)
Also all my problems related to sync happened while playing on one PC, never when I was switching laptop/desktop.

Now I just keep in mind I can’t just switch it off immediately, also not sure how much good I would do to GPU if its switched off at toasty +80°C, or as it is now, few min later at 50°C.

I just had this problem a few days ago as well, maybe there was a problem with their system. I was able to fix it by logging into Forza on a different device I had just used a few hours before so not much difference, and letting it upload the save to download on the PC with the error.

Still extremely disconcerting given the whole time gated locked cars mess where if you lost your save, even if you had the time to replay the game some of the cars might not be obtainable again.

I have the same error. What can I do? I reinstalled my pc, didn’t back up forza. I had almost every car played since day one. Most of the cars are not obtainable again. I’m worried af.

The last try that you can do is to delete completely the local save and let the game download (sync) the save stored in cloud, if the error reappeares also after the cloud sync, this means that the cloud save is corrupt. In that case the only thing that you can do is to start the game again, unfortunately there are no other way to recover your old save.
As per my own experience I backuped and stored, every day, the last three game saves, just to be sure in case of corrupt save.