I cannot race on the Road America track!

I don’t know if anyone else is experiencing this, but every time I try to race on the new Road America track, I get maybe five seconds into actual racing and the game kicks me back to the Home screen on my One.

The loading screens and annoying intro play as normal. The cars line up as they always have. The race starts and as the pack is approaching the first turn (any variant of the track), the game cuts out and goes to the Home screen prompting a restart of the entire game.

What’s worse, now it does this exact same thing when trying to race in Atlanta.

What’s going on?

Also, I read the announcement for the Booster Pack. The announcement says it’s “free”, but the LIVE Marketplace says it costs five USD.

What’s going on? I would love to race these two tracks, but apparently the game thinks I don’t need to.

Can anyone offer some insight?

I’d try going to http://support.xbox.com/en-US/browse/xbox-one?xr=shellnav and opening a “chat with an ambassador” session. They can give you some advice, and if needed, help you open a support chat session.

I’m afraid I’m unable to help with the crashing you’re experiencing, the last patch fixed it for me. What I’d suggest is a full shutdown of your console, maybe even unplugging it for a bit and then rebooting it again, also check to make sure all your downloads for patches/updates were installed. As for the quoted part about the “Free” car pack, it is only free if you had purchased the car pass, which includes the regular monthly DLC. If you didn’t get the car pass it treats it like a stand alone pack to purchase and download.

Well, I ended up getting it fixed.

After doing a hard restart of my One, nothing changed so I deleted my download of Forza 5 on my HDD and reinstalled the game. Upon starting the reinstallation, the game prompted me to go forward with an 8gb update for Forza 5, once that and the rest of the game install were done, everything works just fine.

I can now race all versions of the Road America track, and I’m able to race on Road Atlanta again as well.

IDK if it had anything to do with it, but in the Class races (part of the “campaign”), when Road America was added in, It was juxtaposed with where Road Atlanta used to be in the track rotation. It says I have a Gold finish in the race (though I haven’t raced any version of RA in the “campaign”, and my Road Atlanta track is showing as “New” with no medal finish to it.

Also, when I went into “Track Toys” to start that series (a series I had not yet raced in any races), Road America played just fine when I got to that particular race. After that, I went to try it in other series’, and it worked just fine.

Turn 10, you may want to check that out. Just a suggestion.

I am having exactly the same problem with crashing on road America every time. I’m glad to see your problem was fixed, Turn10, many others still have the crashing problem…

If still experiencing this problem try first the complete shut down of box, hold down power button until it shuts down, disconnect power cable just to be sure, give it 5 mins or so then reboot. If this does not fix it, try uninstalling forza game and reinstall, it should prompt an update, then wait until its 100% installed, again just to be sure. Hopefully this will fix it as the last update seemed to fix this issue for most people.