Horrible LOD issues on PC and flags flickering!!! STILL!?!?!

So I play this game on both my PC and my XBOX ONE X. And I have noticed that when racing at night on PC (on the highest settings, I run a Titan X Pascal), especially noticeable at Daytona Oval Night setting that the cars LOD is ridiculously aggressive. The cars only have to be 50m ahead and the game switches to very low IQ models that have NO WHEELS! It looks ridiculous! A race full of floating cars!!! And this doesn’t happen on the XBOX (the normal one or the X), This needs to be fixed! Plus I can’t understand that after all of the patches and updates that the crowds at track-side still are flickering out like crazy (the ones that are waving flags). It is VERY distracting while trying to race. Please guys get it together! Fix this game on PC already!!! I have included a screen grab of what I mean below. I zoomed in and cropped it so you can see the issue.

1 Like

I have the flickering flag issue all the time as well. The cars having no wheels is pretty weird though. I run maxed out settings including AA at maximum at 1080p upscaled and haven’t seen that before. I have a 980TI.

1 Like

Like I mentioned try racing at Daytona in a night time race (race at the oval). Then you can see easily what the game is doing. It does NOT do this during the daytime race. Anyway I have been able to reproduce this on all three of my Gaming PC’s… So I know it’s not simply my one system. Try it and see if it happens to you…

Had it happen before, but for me it’s not always happening.

Hi,

So I have had this issue and decided to experiment (mess around) with the graphical settings a little and I think I have discovered the problem regarding the awful LOD as shown in your first picture. So I went into video options and set dynamic customization to ‘default’ instead of custom and noticed the awful LOD issue with cars disappeared entirely when racing at night around Abu Dhabi. I then went into each separate video option and discovered that ‘Car Model Quality’ is causing this problem for me at least. Before I had every setting set to max and so I went through every option and turned them from ‘Dynamic’ to High or Ultra except for Car Model Quality which I kept at Dynamic and I think that as solved the issue for me without (hopefully) decreases the look for the game. As long as you have Dynamic Render Quality set to what you want (Ultra for me) then the game should still provide Ultra quality Car Models Quality when driving close and get rid of that awful pop-in affect.

Would love others having this issue to give this a try for me please. Just to make sure.

2 Likes

This was a permanent game breaker for me and this fix has been the only thing that fixed it - nice one!

@saitenmar … thx for that workaround, it worked wonders . GJ! i didn’t notice any popins/popouts in night races (so far). it was indeed visually horrible to drive@night.

it’s funny i 've refunded the game cause flags and LODS night race were bad and bugged, this month i re-buy the game and nothing has changed…i will ask a refund again.

GUYS I HAVE FOUND THE FIX, now the game is awesome !!! (GPU 1080TI, 4K ultra)
so THIS IS THE ONLY ONE SOLUTION, for the moment

—For flags flickering—
-use RENDER SCALE only at 100%, more will introduce flags flickering.
-use SHADOW QUALITY only at DYNAMIC, Ultra,High or anything else will introduce flags flickering.

—For LODs at night race—
-use CAR MODEL QUALITY at DYNAMIC, anything else will introduce a very bad LODs.
(if you race by day you can change this settings to ULTRA, it’s more beautiful than dynamic by day)

THANKS TO ALL, now i enjoy the game, and TURN 10, maybe fix : SHADOW QUALITY (introduces flags flickering), and CAR MODEL QUALITY (introduces LODS by night)

Didnt someone already post that in this thread about a months ago
Post #5

Yours may be a little clearer though

i have found the flags flickering fix

So tell us how to solve it?

I have flickering too: Forza 7 Crowd & Flags Flickering - YouTube .

Only form in/on car views.

Additionally I found that with GSync there is no flickering. But game stutter. So I prefer static sync but then flags and crowds do their “ghost dance”.

I made topic for this: Forza 7 PC - crowds and flags flickering - Community Support - Forza Motorsport Forums

—For flags flickering—
-use RENDER SCALE only at 100%, more will introduce flags flickering.
-use SHADOW QUALITY only at DYNAMIC, Ultra,High or anything else will introduce flags flickering.

—For LODs at night race—
-use CAR MODEL QUALITY at DYNAMIC, anything else will introduce a very bad LODs.
(if you race by day you can change this settings to ULTRA, it’s more beautiful than dynamic by day)

All the game at dynamic render remove flags flickering, but obviously, it’s not as beautifull as without dynamic render.

If you use exterior/chase cam, there is no flickering, there is an issue with LOD details for cockpit view, i have e-mailed and contacted many times devs. They can’t give a solution, they have refund me without trouble two times, each time i have re-bought i thougth teree wil be a fix. I can now pre order forza horizon 4 ultimate, i had F7 ultimate

But my biggest issue was the micro freeze, it’s the only game with that, i had random micro-freeze. I don’t know why. i have re isntall F7, windows 10, all, but everytime micro freeze with F7, not with FH3, not with FH4 demo.

This still needs to be patched! I don’t remember this problem existing at launch. I’ve tried lowering the CAR MODEL QUALITY to high but there is a harsh transition between assets on that setting.

I always wondered why we had LOD issues at night. This explains it.

Thanks to everyone involved for finding the issue and providing a temp. solution.

For Nvidia go to:

NVIDIA Control Panel → Manage 3D Settings → Program Settings → Forza Motorsport 7 and set Texture filtering - Negative LOD balance to Clamp.
This has fixed the LOD issue for me, not the flags though.

Edit: This “fix” for the stuttering issues also fixed the flags for the most part. Only works for GTX 10… cards.

It seems the dynamic clock frequencies of the GTX 10 series is causing the problems. So with this workaround I’ve all but eliminated the stuttering:

  1. Dowmload and instal MSI Afterburner.
  2. Open Afterburner
  3. Press Ctrl+F
  4. Select a point on the highest 1\3rd of the frequency curve. (you’ll have to find the sweetspot for your system.)
  5. Press L
  6. Back in the main panel click aply.

Now your card is locked to the clock speed you selected and the stutters should be gone.

To go back to dynamic clocks simply pick a different profile in Afterburner.

Hi all, this is my first post in this forum.

I’m not sure if this was discovered already by someone else but I fixed the flickering flags by using Riva Tuner Statistics Server (RTSS) and pegging the framerate to 60. It seems like the game engine is aggressively keeping the frametimes to a certain value and when it exceeds that the flags are the first to go. When the flags go away the frametime budget is met then the game puts the flags back. Then the frametime budget is exceeded again so it removes the flags. This goes on and on as long as the frametimes aren’t consistent.

On my PC with RTSS locking the frametimes to 16.67ms (for 60 FPS) the rendering of flags was finally stable and they no longer flicker. I was also able to put every graphic setting to wherever I wanted them instead of Dynamic. I have a GTX 1080 and i5-8400 btw.

Hopefully this helps.