Game doesn't get passed loading screen

Hey everyone,

I’m unable to load into this game. It plays the intro video and then gets to a screen with a blue Ford car and a small spinning circle in the bottom right.

First time I opened it, I had to sign into my Microsoft account and then it gave me a PC doesn’t meet specs message. Then it just sat at that screen and the little circle would spin randomly.

Closed the game and tried again. Doesn’t ask me to sign into anything or give me any messages. Circle randomly spins. Any help?

My drivers are up to date. I have a G3258 and a GTX 970, and 8 GB of ram.

Make sure you’re running the most recent NVIDIA driver, Run Windows Update, then run dxdiag and report the information here. If a solution isn’t available in this forum you’ll need to contact Xbox Support:

welcome to the club we gather on Thursdays


I read somewhere that lowering the screen refresh rate to 60hz might solve this problem.

I had just uninstalled the game thinking it was corrupt, so I’ll try this in the morning. The game kept crashing on the GT40 loading screen. Windows 10 fully updated with latest Nvidia drivers.

I tried it with my screen set to 60hz, and the game loaded and plays fine.

It’s really disappointing that I can’t play at 165hz, but the game looks great at 1440p with everything maxed. I only wish I didn’t have to do the first race with everything looking terrible before getting the chance to configure the graphics.

still the same for me @ 60 and 50 hz

The G3258 can’t run the game it misses a certain instruction set.

Even the celeron can run this game.

Getting past the loading screen