Game crash after main menu (PC)

Hi everyone! I play on PC.
After the last patch is impossible for me to join into the game cause on the first loading screen, when i press the "Continue button the game crash to desktop after a bit i’ve been in the loading screen.
Someone else with the same problem?

1 Like

Jupp - I have the same problems, need to start the game up to five times to get at least the game running. The problems started for me after the new season yesterday.

if I switch to a custom wheel-profile at gamestart in options on first screen mostly I get away with no ctd
but if I just press continue the game will crash…

(because of the bug that the game don’t remember which custom wheel-profile I had last time and keep swichting to the default wheel-profile on every start I have to do the wheel-profile change at every game start anyway…)

I had the same problem, mine was solved by changing my Anti-Virus from Bullguard to Windows Defender.

Other players have also mentioned other AV programs as being the cause of the issue.

Sometimes, I have to start the game 4-5 times. Once I finally get in the car and can drive, though, I am good to go for hours. So, just keep restarting for the moment.

I have the same issue. I re-installed the game and it was working fine for a day and this morning I cannot get into the game. As soon as I say continues and it starts to load it will kick me out to windows. No errors just crashing. I don’t really want to keep re-installing to play the game.

I play on PC Windows Store version, Everything works nutil this patch. After the last patch is impossible for me to join into the game cause on the first loading screen, when i press the "Continue button the game crash to desktop. it’s just quit the game. Help?!

Xbox series X user and it is the same for me I finally got some time to play and cannot even get into it. As soon as I click the continue button on the welcome screen the game crashes back to desktop I guess I’ll miss out on the season and series rewards.

https://forums.forzamotorsport.net/turn10_postst171947_Series-X-game-crash-on-loading.aspx

Try multiple times it starts in most cases on third try or 4th …

Ok I’ll give it a try tomorrow if I get some time, thank you for the help.

I’ve been having this issue after the last update too. Although the issue is on both my Xbox and my PC. I can load into the start menu fine but as soon as I hit continue the game loads for a second then freezes and closes. Very frustrating.

I’ve never had problems except for always having to launch the game as admin. But since 2 days I can’t play the game anymore at all. Same problem game just crashes after initially launching and pressing continue. I’ve tried literally all the suggestions the internet throws at me. Nothing works. PC player.

It was fixed, right?

Few things to consider :

  • Game is very sensitive to 3rd party security apps / overlay apps, do a clean boot of Windows and try again
  • Game is very sensitive to external controllers, wheels, other usb related devices, unplug all usb devices except keyboard and mouse, try to start the game again and see if it works without crashing.