G920 external hand brake (PC)

hi all, i’m having some trouble setting my “hand made” handbrake on horizon 4, it works perfectly with FM7 but on horizon when i try to create a custom wheel layout and set the Ebrake after leaving the settings the key assigment is missing for the ebrake. any solution guys? my Ebrake is like the one on the video below works perfectly on every game i have excluding horizon 4:

1 Like

I have the same issue and I don’t think there is an update for it yet.

Due to a bug in the release version of Forza Horizon 4 mapping multiple devices in a custom profile is not possible through game options. So you need to locate the file and set the handbrake manually.

We can help you with the workaround on FirstPlatoLV’s Discord channel.

i exported my settings from the demo like said over other foruns, it works but i’m having some bugs, i can’t put sequetial gears on 3/4 gear on the knob and sometimes in game in 1st/2nd and reverse i acelerate, de rpm go up but the car doesn’t move is like its on neutral

Copy/paste from demo to final game is not enough, you need to set them manually in the file, also deadzones, etc.

Gear + - are stored in values 4 - 5:

<InputCmdLow VidPid="74302050" InputType="Button" Index="4" IsPrimary="1"/> <InputCmdLow VidPid="74302050" InputType="Button" Index="5" IsPrimary="1"/>

Manual gears are stored in values 195-202:

where 195 is reverse, 196 is 1st… 201 is 6th.

So… you are looking for this:

<InputCmdLow VidPid="74302050" InputType="Button" Index="13" IsPrimary="1"/> <InputCmdLow VidPid="74302050" InputType="Button" Index="14" IsPrimary="1"/>

that is my settings what should i change to fix my gear bug and fix the aceleration issue?

value keys 0, 1 and 6 are accel, brake and clutch, respectively, So if you are saying rpm go up but the car doesn’t move is like its on neutral means clutch is pressed so i would try these 2 options:

<InputCmdLow VidPid="74302050" InputType="Axis" Index="3" InvertAxis="1" DeadzonesAroundCenter="0" InnerDeadzone="0.200000" OuterDeadzone="0.750000" IsPrimary="1"/>


<InputCmdLow VidPid="74302050" InputType="Axis" Index="3" InvertAxis="0" DeadzonesAroundCenter="0" InnerDeadzone="0.200000" OuterDeadzone="0.750000" IsPrimary="1"/>

More things, handbrake:

Maybe you want to fix deadzones too:

<InputCmdLow VidPid="591495222" InputType="Axis" Index="1" InvertAxis="0" DeadzonesAroundCenter="0" InnerDeadzone="0.100000" OuterDeadzone="0.900000" IsPrimary="1"/>

And taking in count the vidpid were correct but handbrake wasn’t working would need to fix Axis Index:

InputType=“Axis” Index=“1” InvertAxis=“0”

Index could be: [0,1,2,…n]

the handbrake already worked, and now the gears are correct, the aceleration is the problem now… in order for the game to recognize it i need to change gear, it must be a conflict between the devices now cause i made some tests on the FM7 and the same thing happens. any idea?

i don’t get what you are describing but if you have buttons 13 and 14 binded to values 4 and 5, make sure they are also not binded to 197 and 198. otherwise, you will have issues:

You can just set vidpid=“0” in both