Forza Horizon 4 not launching - Windows 10 version 1903

Last couple of weeks I have been unable to launch FH4, I see the splashscreen of the Senna and it just closes itself. I have updated everything I possibly can, I’m on Windows 10 version 1903, Nvidia drivers updated, Windows Store is updated,…

I have tried getting it to work by uninstalling and reinstalling, 3 times by now. Resetting the game doesn’t fix anything.

I have uninstalled and reinstalled the Windows store with powershell commands, doesn’t fix anything.

I have followed everything posted here, doesn’t fix anything.

In Event Viewer I get the following error codes:

Event ID: 1001 / Source: Windows Error Reporting
Fault bucket 1213432593642158644, type 5
Event Name: MoAppHang
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft.SunriseBaseGame_1.313.159.2_x64__8wekyb3d8bbwe
P2: praid:SunriseReleaseFinal
P3: 0.0.0.0
P4: 00000000
P5: 07c1
P6: 4194304
P7:
P8:
P9:
P10:

Attached files:
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERAD77.tmp.WERInternalMetadata.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERADC6.tmp.xml
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERADC5.tmp.csv
\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERADF5.tmp.txt

These files may be available here:
\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppHang_Microsoft.Sunris_5642fa823f51cd124596e3f250b1c61db16eb0_3e5ea878_bfee01fc-02ce-4929-b135-a4d68fce92c0

Analysis symbol:
Rechecking for solution: 0
Report Id: e4f6a20a-24a8-4b15-82d5-f0d014f83fbb
Report Status: 268435456
Hashed bucket: bb2cca60f2f766bae0d6fa83ceebfa34
Cab Guid: 0

The program ForzaHorizon4.exe version 0.0.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 19f8
Start Time: 01d52365d106c662
Termination Time: 4294967295
Application Path: G:\WindowsApps\Microsoft.SunriseBaseGame_1.313.159.2_x64__8wekyb3d8bbwe\ForzaHorizon4.exe
Report Id: e4f6a20a-24a8-4b15-82d5-f0d014f83fbb
Faulting package full name: Microsoft.SunriseBaseGame_1.313.159.2_x64__8wekyb3d8bbwe
Faulting package-relative application ID: SunriseReleaseFinal
Hang type: Activation

Anyone who has any idea how to fix this? I’ve paid enough money to play this game with all of its expansions. :confused:

3 Likes

I have the same problem, the game closes on the loading screen when I press to play … before it was working normally. Try to reinstall for me only if it is sure to work, because I stayed 5 days to download!!

1 Like

I’ve already reinstalled 3 times, so that’s about 240 Gb worth of downloading… Haven’t found a solution yet. No answer on my week-old support ticket either.

1 Like

same problem here after new update:

Can not start DCOM server: Microsoft.SunriseBaseGame_1.313.159.2_x64__8wekyb3d8bbwe! SunriseReleaseFinal as Not Available / Not Available. The mistake:
“2147942405”

Sincerely I will not download 100gb again and I will cancel the gamepass.

1 Like

So annoying to have paid so much money to not be able to play the game.

I have the same problem. also send a ticket of my crash file. just got the game with ultimate edition… so salty i got to play 6 hours and now not working

Same here, I reinstalled and nothing happened. It’s ridiculous, they make you update windows to break the game. And my friends with the same build (1903) are playing normal. I think it is something about the save, because when I reset the game, the game starts to sync my profile, and when it finishes, it crashes. I’ve tried every fix there is on the internet, but nothing works, this is a new problem nobody knows how to fix yet!

I’m still waiting on a reply on my support ticket, must be about a week now…

Yeah, it’s pretty unbelievable that this can happen with such a big developer. :confused:

Similarly, after synchronizing the game data, I tried to disconnect the network and create a new archive, but I don’t want to start again.

I have the same problem after lego update.
The error in the event viewer is exactly the same as yours.
I reinstalled the game, store, xbox app, and it didn’t work

First of all: please keep in mind that I am not specifically familiar with the problem above. Figured I’d mention that to avoid creating false expectations.

But here’s the thing… re-installing a game when things stop working isn’t the best idea to start with, especially if we’re talking about a game such as Forza which doesn’t even behave as a regular installed game (it’s not in “Program Files” for example). The chances that the game itself got corrupt is quite low (unless you tried to apply some modding of some sorts I guess) so it makes no sense.

Instead you should try to focus yourself on the game settings, optionally cache data and stuff like that. See: if something went wrong with the game data then re-installing the program files won’t change anything. And game data is written and accessed a lot more than you might think.

So far the good part. The bad part is that this is a Microsoft store game (UWP iirc: universal windows program or something) and as a result everything is different. You’d expect your game data to appear in “My Documents\My Games” but nope… Instead it’s buried in “%appdata%…\Local\Packages” somewhere (enter that link in your file explorer and you’ll see what I mean… Careful: do not mess with anything in this directory because that could seriously damage things!).

But if you can pinpoint where Forza Horizon stores its game data (‘settings’) then you can remove that which I assume would reset the game settings to default.

I know this isn’t helping much, but this is what I’d start looking for: a way to reset all your settings.

But honestly: reinstalling a game usually never works, because by removing the program files you’re not removing the program settings and other data.

2 Likes

Well, I did uninstall / delete everything I found about FH4, that includes the folders the Microsoft Store creates… So I must have deleted all my settings at one point, I guess. Nothing really works, I’ve tried every single “fix” that I could find on the internet, nothing works… Haven’t tried reverting to Windows 10 version 1809, and I’m not going to at this point.

Still not working, still haven’t heard anything from the developers… Should I charge back the money I’ve spent? :confused:

Well, I have exactly the same problem here, try everything, upgrade windows get back on the anterior version and not working on both.

Have you tried an older/newer graphics driver?

I don’t care if you have the latest a greatest driver, sometimes it pays to go back a driver update or two when you have issues after a new game or OS update.

The only thing that I have updated is Windows 10… It worked okay-ish on version 1809. Can’t go back to the old OS version because, well 1) I shouldn’t and 2) I can’t because I deleted the files to restore back to that version of Windows.

Same for me

when i reinstall the game, it works ONE time, the second time i’m trying to launch the game, it crashes on the loading screen

1.43GB update this morning and unfortunately it hasn’t changed anything…

Here Same Issue

Faulting package-relative application ID: SunriseReleaseFinal

Its pretty sad they must fix this issue

Same issue after 1.317.24.2 update. Before this, it was working perfect!