Forza 7 Won't Launch on PC

It opens up the splash screen and disappears. I’ve played earlier today and it won’t launch now, tried restarting and it didn’t help.

I’m able to launch other games fine including the Forza 7 demo.

2600k @ 4.7GHz
8GB Ram
GTX 1080


Was able to launch it yesterday and tonight same thing happening.

Same here.

Not working Wednesday.
Working Thursday.
Not working today.
Note that it is the same for both Horizon 3 and Motorsport 7.
When one is not launching, the other one won’t too.

This is an issue with Windows Store and Xbox live and not T10. There are a number of options available…

Download any random free app from the Windows store, this can sometimes “force” the reassociation of the account

Go to start> settings (cog wheel)> apps

Scroll down to Forza app. Click on it. Click on the “advanced” link. Uninstall/reinstall any/all DLC

Scroll down to Xbox app. Click on it. Click avanced, hit the reset button

Scroll down to the windows store app, click on it. Click advanced, hit the reset button

Right click the start button, from the list, select Command Prompt (admin). In the box type wsreset.exe

If all else fails, you can reset one of the the Forza game apps. This will delete your save so you will need to ensure your cloud save is up to date.

If it’s still not working, unfortunately the uninstall/reinstall the game option is the only one that remains

1 Like

^^ This worked for me… Thanks!

All of those but the last one work. unfortunately the game is almost 100gb. how about we step into the real world and realize that is days worth of connection time for some and hours for myself. I have had to do this 1-2 times per week since the creators update and thinking its time for a fix.

Hey I’m just trying to help. I don’t work for T10 (whose problem this isn’t) or Microsoft (who are the ones that need to fix it). There’s no need to take issue with me. so I’d appreciate it if you didn’t. Thanks

“Download any random free app from the Windows store, this can sometimes “force” the reassociation of the account” worked here too.

Have your Windows 10 account be the same as the Xbox Live account. That should fix it.