Forza 5 won't load tracks

Hi there,
I originally purchased an Xbox One at launch with Forza 5 but had to sell it in February of this year. Last week I decided to buy another and again got Forza 5 and, after my game save synced with the Cloud I was able to continue my game and it worked perfectly well. Then all of a sudden I attempt an event and, on the track loading screen (where you’re given all the track details such as length, time, temperature etc.) it just kept loading (or not loading) permanently. This was on Spa, the second race of the classic F1 race series. I pressed the Xbox Button and closed the Forza 5 app, but was unable to reopen it, the console could navigate just fine, but it would not start Forza. I had to do a full system restart. I started the game up again and decided to exit the career series and began another event, this time it froze on the same screen, but for Catalunya.

I decided to uninstall the game from the hard-drive and re-install. This took approximately 18 hours as I’m not exactly blessed with the quickest Internet connection. I waited for it to be 100% downloaded before starting.
The game hung in the exact same place. Loading screen before the race.

Thinking my only option was to reset my career by pressing in LT+RT+LB+RB+Y I went ahead and did so and to my relief it reset the game, I ran through the intro, through the first race on the Alps worked perfectly fine and then bang, stuck on an eternal load before the Top Gear Full Circuit in the first series in Career.

What’s going on, how do I fix this problem? Fifa 15 is working fine on the Xbox but Forza 5 continues to hang on loading screens before races!

Hoping for some help! Thanks,

Sorry to say that there is no resolution to this problem. I have called Microsoft like 50 times on this and they give me the same power down instructions that do not work. I was able to get a full refund from Microsoft as they saw that this issue is on going. it is really irresponsible of Turn 10 to not take care of this as apparently it is a problem that is affecting everyone. Hope this helps

Apparently there was an update to resolve this issue yesterday. Go to system updates and perform the update to see if it working. I have not had a chance to try it out. Here is hoping it works