FM 6 stuck on loading screen?

I just installed the 108 mb update, and now when I try to open fm6, it gets stuck on the loading screen, the one with the Ford GT taillight. The load thing in the corner still spins, and music still plays, but its been sitting there loading for about 15 minutes now. Has this happened to anyone else?

Try doing a system reset (hard boot) as below:
1 – from the Dashboard, out of all games, hold the X button on the front of the console down until it shuts the system down.
2 – Disconnect the external power from the wall plug (or at least disconnect the wall-side connector on the power pack itself).
3 – WAIT until all power drains from the external power pack (no light, either white or dull orange showing on the pack).
4 – Reconnect the power supply to the electrical outlet.
5 – Restart the console in the usual manner, i.e., either with the controller or a short push on the X button on the front of the X1.
6 – WAIT until the console self-checks and fully boots to the Dashboard before attempting anything.

If you don’t disconnect the external power pack and let the power completely drain out, the system is still retaining “old” stuff and not resetting. If the system wants to do an update, let it complete before attempting anything or playing a game.


Thanks Snowowl, of course that worked like a charm. I had closed the game out by opening another, but hadn’t tried the old ‘turn it off and then turn it back on again’. I even work in IT, so I should have known better!

Thanks again!