(FIXED) Wheel Mapping PC on Logitech G920 bug when remapping + controls

Okay so simply when I create custom wheel profile bind my E-Brake to button 5 that was originally Shift up its works but also is shifting up.

So basically I have shift up /shift down unassigned but they still works.
I just want only E-Brake (handbrake) on button 5.

Is there any possible fix for this ?
Or I still need to use Button A for handbrake ?
Its really annoying.
Thx ! :slight_smile:

EDIT:
Fixed

I just mapped
shift up to DPAD up
shift down to DPAD down

So happy :smiley: finally using my e-brake on RB (button 5)

Here is my settings :

Credits to : Propulsion Unleashed YOUTUBE : Forza Horizon 4 Best PC Settings For Logitech G29/G920 Wheels - YouTube
Controls 1 :

Controls 2 :

Controls 3 :

Controls 4:

Advanced Controls :

Advanced Controls :

Difficulty settings :
Also make sure you use “Normal” steering setting and not “Simulation” under difficulty settings in Forza Horizon 4. Changing default 900 degrees rotation to 600 degrees also helps greatly, you can do that by using Logitech Gaming Software driver.
uncheck Centering spring.

You are lucky to have a custom wheel profile you can actually manipulate :wink: Mine comes and goes and cannot be altered