Fix for freezing while loading FH4 (after LEGO DLC)

I have found a way around it myself but I have no clue if it works for everyone yet.

First I made sure to go into apps in my settings.
Image 1

Then to FH4 (clicked advanced options)
Image 2

chose to terminate the app. I then reset the app in order to force it to re sync my save data upon next launch.
Image 3

Second I scrolled through the DLC list that shows in the same area where I previously terminated and reset FH4. Chose the Lego DLC and then uninstalled it.
Image 4

(Next part may not be necessary), in the app selections area where you find FH4
Image 5

I also went to the Microsoft Store app and terminated it.
Image 6

Third, just go to the Microsoft Store app and download the Lego DLC again.
Image 7

(If the images do not load, here they are in chronological order.)

Upon launching the game, I made sure not to fly through the menus. I waited a bit before hitting start, then also waited a bit before hitting continue. (Important) Once you have done this, it should load you in to the Lego DLC itself. Immediately pause your game, go to the part of your menu that allows you to travel to the mainland, or just drive to the teleport on the Lego map. When you load the mainland, head straight to the garage. There should be something at the bottom of the screen that says “set as home” or something along those lines. Push that button and play on the mainland for a bit, or head to the Lego island. After a while, close your game and reopen it. You should load fine after this has been done.

~Basically the problem is having the Lego island DLC being your spawn point, I have found that if you can change that by any means. It’s sad but that’s what I have come to realize.~


This is a workaround that worked for me. Thank you very much. Additionally - I recall that I force closed the game the time before this crash actually started happening - hitting the X on the app to close it. I had been in Lego Valley when I did that.

I was able to play the base game, then trigger the expansion install from within the game, and continue playing while Lego downloaded and installed in the background. I could then travel to Lego Valley once it was installed without restarting the game. I will make sure to travel back to Great Britain prior to exiting the game in the future to avoid the possibility of this happening again.

1 Like

Thank you very much for this! I uninstalled the Lego DLC and the game started without any issues!

1 Like

Thank you! This fixed it for me.

In my case it is also possible that it crashed because I was able to upgrade the lego house for the first time but I quit the game before doing that. This might resulted in the house getting bugged for spawning in there. Following your instructions worked for me and I just upgraded the lego dlc house before spawning in there again.

It finally works again now!

1 Like