FH4 (XB1X) stuck after completing 1st stunt event

Hi - just started playing FH4 today but am experiencing a technical problem.

After finishing the first stunt mission (where you get chased by the jet then jump through the arch), I get a ‘3 STARS EARNED - YOU NAILED IT!’, at which I press ‘A’ to continue, but the game won’t progress - it’s just stuck playing the animation and music.

I quit the game and restarted, but my completion of the event hadn’t saved, and when I completed it again the problem reoccurred.

1 Like

Have you tried properly restarting the console from the console settings screen …or the off screen where it says restart console

Just turning off and on does nothing

1 Like

You’re not playing the demo are you?

1 Like

I’m having the exact same problem. Xbox one x, just finished the first stunt driver event, 3 stars, hit A to continue and then I sit looking at “you nailed it” until I get tired of listening to the music and exit the game. Have tried quitting and restarting the game, rebooting the console, cursing, and every button combination known to man.