Ferrari 330P4 Aero Glitch

I just won a 330 P4 front a spin and proceeded to go modify it. I added the aero package to the front and rear and notice that the speed actually increased with the downforce mods. I thought nothing of it until I went into the tuning area and found that the downforce was set to zero front and rear and would not allow you to modify the downforce settings front or rear on the car. Anyone else having this issue? Anyone else care to chime in?

1 Like

I bought a 330 P4 for the career mode and noticed this too. Adding the race aero sets front and rear to 0 and no way to modify the settings. Hope this can get fixed.

Ditto. The race wings say adjustable when you buy them but don’t adjust and apparently provide no downforce.

Yea this bug has been present since the start.

Buy the ferrari 330 p4 and put aero on it, then go to tune the car, notice the forza aero is 1) not adjustable 2) seems to be 0

This appears to be a bug and haven’t seen anyone mention it.


Just noticed the same thing. You put on the adjustable wings, but when you go to setup they are set to 0 front and back, without a way to change the setting.
Really cool car, would be nice to mess with the wings a bit to get a proper setup.
Please look into this.


Has this been fixed? Love this car from previous forzas enjoy tuning it but with the aero not working???

Just do what I do and run without aero! I’m obviously biased as I work on vintage cars for a living, but I find racing without aero to be much more rewarding and challenging.

Obviously that doesn’t excuse this bug, but that way you can enjoy the car. You can still be competitive without aero, so don’t worry about that.

While I understand what you are saying- to me it is much less rewarding. The reason being that while I may be rubbish at tuning it is part of the overall challenge to me to tune the car and while I dont typically go full bore with the aero downforce settings it is part of my overall gameplay. I am not sure why they habent fixed it and I am not going to buy it again just tonfind it doesnt work.’

Really weird to me that they havent fixed it ornat least explained why it is as it is in the game. Just irritating to me but I’ll get over it. Now it is more about being curious as to why they have the issue.

Turn 10 is their a chance this gets fixed? ??

Just encountered this today. I can’t believe that this never got fixed. Shameful!