Failed To Acquire server data when trying to join a online lobby

Whenever I try to join a lobby in online I receive a “Failed to acquire server data.”

Be great if yall could help me with this

I get this from time to time as well on xbox one. I find that if I fully close and restart the game, it’s happy again.

If you are on PC you can try and restart the (xbox) teredo adapter, this always works for me. If not on PC, than forget what i said :-).

Open powershell as admin:

netsh interface Teredo set state disable
netsh interface Teredo set state type=default

Basically stops it and starts it with default settings.

I tried the Netsh Teredo stuff & restarted the PC & Updated Forza 7 but still getting “Failed To Acquire Server Data”. I tried DMZ & Disabling firewall all together & IPsec but it’s not working.

Advice? This is a connection DD-WRT bridged wireless mode my PC connects via Ethernet & before with direct connection worked but the DD-WRT might be getting in the way or something?