Download size exceeds 60.2 Gbs

Hello all

I have been trying to install the game for the whole weekend.

At first I saw the download normal and I didn’t worry. Then it started to say it was about 50gbs into it. I read that the download is only 18.3 gbs so I have no idea what is going on.

Any light any of you could shed on this matter would be highly appreciated.

My Specs:

Nvidia GTX 760
Core i7-720
12 gbs of Ram
500Gbs on Hard disk
Windows 10 fully updated

Oh and here is a picture of the download on the store
Forza Super Sized indeed

I don’t think you would be able to run the game. Do try though. Best of luck

I would be able to try if it ever finishes downloading. My question is not whether I can run it or not, is how can I make it finish installing?

Hello.

There’s obviously something wrong with your download. Please delete it and try it again from scratch.

On the other hand, I highly doubt Apex will run with your i7 720 since people with the much newer 2600k and a 980Ti already having big problems.

But please post your dxdiag info file for full system info. …(how to)

I cant Cancel the thing. I press teh X and it just resumes afterwards exactly where it left off, as if it just doesn’t delete the files. I tried WSREST-ing the Store but to no avail. this is my DXDIAG

Already tried this …

Please post the dxdiag file with the full info, not a screenshot of the main window.
For the how to … see the link in the post above.

There’s nothing wrong with your CPU. You should be able to run the game fine as long as you have the latest updates of Windows 10. It plays great on my machine and look at my specs. However, there is something wrong with your download. It is only about 18GB in size. I would cancel the download and start over. You may have to go in and manually delete what you have gotten though.