Difficulty Setting - Shifting - Manual Un-Maps Map Button

AFAIK, this is only an issue with Controller Default Layout 12. Other Default Layouts seem unaffected.
Affects both PC and Xbox.

  1. Go into Difficulty Settings and set Shifting to ‘Automatic’.
  2. Go into Controls settings, Controller, and choose Default Layout 12.
  3. Notice that ‘Map’ is mapped to the View button.
  4. Go back to Difficulty Settings and set Shifting to ‘Manual’ (or Manual W/Clutch).
  5. Go back into Controls settings, Controller, and choose Default Layout 12.
  6. Notice that ‘Map’ is now unmapped.

FYI, this annoying issue has been present since at least Forza Horizon 4 launched.