Connection or game issue?

I only drive an F1 car only assist I use is half of the traction… (Manual no clutch) I have a good connection (wireless) I have run all the xbox one connection diagnostics and everything checks out. However the last couple weeks I have had major problems with revs dropping, typically when coming into a corner. Sometimes on straights but not as bad. I have even noticed the steering trying to correct itself. I have double check that there are no breaking/steering assists turned on. I bought a second signal booster to see if that would help and it did boost connection a bit but the problem still persists. Titanfall works totally fine every time so I really don’t think this is just a connection issue. I played this game online since launch and had no problems till now. It is happening online as well as in free play and career modes

That doesn’t sound like an internet/connection issue at all.

My only thoughts are it could be something as simple as a poorly geared tune. Have you changed or re loaded a tune on that car recently? Could also be a controller issue. Have you done the update?

You could always try to reinstall the game if you think something funky is going on. It takes a good 8-10 hours to reinstall so do with caution.

If you can catch it on video post that up, someone may be able to help you further.

1 Like

I ruled out the controller on acount Titanfall works fine. Also tried changing the tune… I’m at the point were I may try the re-install… I can absolutely post a video if I knew how… Ill look into it. Thank you for the reply.

I recorded clips in free mode… Can’t figure out how to upload them

*downloading upload studio if that’s it.

Sounds like bad braking management, clutch or gearing.

It is not “bad breaking management” and I specified I do not use the clutch. I have been playing this game for 5 years I know how to use the breaks. Also specified I have switched tunes, so it is not gearing

Then why don’t you show us video proof of what is going on then we would be able to better direct you.

Just stalked your videos. I can see what you are talking about. It honestly looks like assisted braking is on. It would be helpful if your throttle and braking input were on your hud or you could show us in telemetry.

-Have you tried buying a whole new car?
-A new tune?

New tune yes, new lotus no. I tried different models of cars and every one of them did it. I can assure you breaking and steering assists are off. I will make another video telemetry right now. It definitely feels/looks as if the assists are on though. I have checked a million times and they are not. Thanks for the help man. Video will be up in a min

This may or may not help but is worth a try.

  1. When on the dashboard hold the power button on the console for 5 seconds until it turns off. Wait until it is totally off. Then restart and try again.

  2. Up the top of the assist screen change it to easy or beginner or whatever the easiest one is called ie all assists on and go and run a lap somewhere.

  3. Exit the game ie go back to the very first menu (the one with press A to start but do not press A) and then go to dash. When there on the big Forza 5 tile (make sure it still shows the press a to start screen) press menu button and select quit.

  4. Eject the disc and then reinsert it.

  5. Let it load up etc and then run a lap somewhere.

  6. Change the assists to what you want.

  7. Run a lap somewhere.


Are you sure you are saving your assists settings and not pressing B?

Also try the stated above. Also try a uninstall and reinstall.

Copy. Yes pressing a to exit assists menu. Thanks again guys. I will let you know if this helps.