Completely broken FPS limit after last update

I have a 75Hz monitor overclocked to 77Hz, so I play my games with V-Sync locked at 77fps, and it worked fine on FH4 until the last update. Every time I enter the game, it’s stuck at 50fps with HUGE input lag, simply unplayable. One time I managed to enter video settings and change the fps limit and change it back and it worked fine, but now the fps limit only showed half and quarter of the refresh rate options, 39fps and 20fps, so, what the hell? I already have enough problems with Teredo being disabled all the time, now this? I’m getting tired of FH4’s issues.

My PC specs:
i7 2600k OC@4.4GHz
12GB DDR3 1600MHz
GTX 1070 Ti OC@2GHz


Seems like it was not persistent, I entered the game, changed back to 77fps and reloaded the game a couple of times and it’s normal now, but I still don’t know why and how it happened.

It has happened again, was playing fine last time and when I opened my game just now, it was stuck at 50fps again (with the limiter set to 77), and I had to change to 39 then back to 77 to fix it.

I’m curious. Why? Would anyone even notice an extra 2fps going from 75fps to 77fps?