Club tag not showing for 3 weeks

I created a club at launch and it all worked fine for the first couple of weeks, however suddenly around 3 weeks ago the club tag and owner badge disappeared from my gamertag and the game is acting like I’m not in a club at all, I can only search or create clubs.

When I search for my club through xbox it comes up and shows me as the owner still, so I have no idea what’s going on. My friends in the club don’t have any issues, it’s just me. I tried to leave and rejoin my club but it still doesn’t work. It has been stuck like this for 3 weeks now and won’t fix. Any ideas? I’m playing on Xbox One X.

Same here. I submitted a bug report, did not hear from them for a couple weeks, then got an email saying it would be added to the known issues list and the case closed.

Since 3 days I’ve nearly the same issue, when I log into the game my club tag doesn’t appear and in the club tab it look like I’m not in anymore, but when I go into my club tank, I’m still in. (Same on xbox club)
I need to apply each time I log in to get my tag back. I’m on series S.

1 Like

I still can’t join or create clubs, been 2 months now

I’m just an ordinary member of a club, and my club tag is not showing for 2 days now (XBOX Series X). Tried rebooting, removed power cord, …, nothing helped. My club membership is still active, just the badge is missing. In the menu, “Recommended Clubs” is grayed out and if I click on it, it says something like “Failed to load …”.

There’s an open issued “Club tag is not displaying for some players. (date added: 2021-11-23)”, but I’m unsure if that covers this case. Will probably submit a bug report.

i have had this problem for 3 or 4 months now and nothing is getting done about it

I’ve been having this same problem. I also submitted a report months ago about this. So far it hasn’t been resolved for me. I am in the Alpha program too. Hopefully that’s not contributing to this problem.