Can't use #66 Ford Gt LeMans

Finally downloaded the car about a month ago or so to prepare for the ForzaRC. Had been using it the whole time. Two nights ago I tried to hop on and run the open league and no car. Shows it in my garage but can’t use it. Its marked DLC. I have checked installed files. The dlc content was there not showing corrupted or anything. So I do a hard restart of my Xbox and now its no longer there. Still shows the car in my garage even with the livery i have designed. I have emailed turn10 and Microsoft with this issue. Only turn10 has replied so far directing me to the forums. This is starting to get annoying. I have had problems with the game ever since this league thing has started and everyone keeps saying its not their problem.

Did you do the full hard reset as per Snowowls instructions including pulling the power plug from the wall until the light on the power supply goes completely off

^ this. Happened to me about a month ago and a hard reset fixed it.

1 Like

I have done multiple hard resets. Still nothing. Oh well, that car was shyte anyway.