Can't connect to online, server connection blocked/NAT Blocked


Posting this on behalf of our friend. It’s no exaggeration that we’ve tried every single fix we can find. This is the last resort because absolutely nothing else has worked and we’re desperate to play together again.

We were all able to play together just fine but one of our friends occasionally gets this issue, except this time it will not go away. He has tried every single fix found online and has now resorted to formatting and resetting his router, this STILL hasn’t fixed it.

If anyone has any suggestions or has had it this bad, please please let me know. I can’t believe it’s still broken considering how much we’ve tried.

We have done all the Teredo state change stuff, but it just doesn’t seem to be “running”? And no, there is no teredo in device manager nor the legacy list. We’ve tried regedit fixes, everything that we can find on google, reddit, the Xbox support pages etc. We genuinely have exhausted everything. We have also tried using a mobile hotspot to rule out any router issue.

Thank you

If you haven’t submitted a ticket to, don’t wait to do that. It’s the most direct way to get support.

We have a ticket but they so far haven’t been able to help.

We’re really desperate here it’s been going on so long, sometimes a fix will work for a day then back to not working.

If anyone can help, please let me know, we’ve tried everything :frowning:

First, when you state that you have tested all, you cut most people will to propose anything. You need to state the exact list of tests done.

There are multiple aspects dig, first is to know whether it is a profile issue or an infrastructure/device issue. For that he will need to find someone around to login with his profile and test all is running fine. From what you stated, it is, but better confirm it for good before digging further on infra/device issue

Second Step, is it the computer ( in other cases xbox ) or the internet access. For that he needs to take his computer to another location with access to internet with a different provider and do a test. If it is working then issue is related to internet provider. Another/complementary way is to bring there the computer+xbox profile of someone else.

Third, issue is narrowed down being on the computer. Proceed with basic check of the computer configuration before proceeding with long procedures.

  • first is date/time, normally only OS datetime counts but worth checking Bios one too. Check if any battery issue on the motherboard.
  • second is testing capacity of the computer to use network : ping time, download speed, upload speed.
  • Then comes ‘put it to stock’ step which consists in removing any of optimization ( overclock, resolution, etc ) and up to date ( apply all the Windows update, drivers etc )
  • Then only comes the "try registry/file tweaking’ etc ( I strongly doubt it has anything to do with that in this case otherwise it wouldn’t have ever worked but … )
  • Last resort is reinstall

Good luck