Button Mapping and You

On PC with an X1 controller, I try to run manual, yet all default layouts lack any mapping to “Shift Down”.

Not a catastrophe, but extremely odd to say the least.

It’s quite annoying to scroll down the mapping list, only to find out it says “none assigned” next to down shift, then have to scroll all the way back up to change which default mapping profile you have selected. You go all the way back down the list just to find out the next 15 TIMES you repeat this process it doesn’t have a single button mapped to down shift, ever.

You see there are some Custom Controller Profiles after all this madness. You think to yourself, a saving grace… nope! Instead, you find yourself in an endless cycle of hell trying to have the only button you actually wanted, “Shift Down”, be over-ruled at every turn with these special “Controller Mapping Required” buttons. Buttons like “Activate Anna” and “Radio Next”, which I could do without, are required and won’t let you play the game unless you have them assigned.

You think you are being clever and start mapping random D-pad and LS and RS buttons to these arbitrary “required” buttons. Finally get back into the game to realize you’ve completely broken the thing, and can’t get back into the pause menu anymore, no matter what button you press on; the gamepad, a keyboard, your daddy’s flight yoke, my son’s boss switch, the neighbor’s guitar hero strum bar, it doesn’t matter.

None of the buttons I’ve assigned to map/activate/quickchat are working(again, buttons that someone might actually need to play the game). But of course Anna is there whenever you press her button, the horn beeps too.

3 Likes

Yep, just another annoyance, won’t be buying this game. I made a thread about this too and it got shut down. It would be really embarrassing if they didn’t fix this by release date.

My X button shifts down and i haven’t changed any settings
On both my PC and xbone
As soon as i changed to manual…the X button became down shift

This is the Default Layout 1 on console (Xbox One X in my case) with Shift Down on X. What’s the Default Layout 1 on PC?

3 Likes

The PC Controls menu is a bit different from console, and doesn’t display a diagram of the controller and the assigned mapping at a glance.

Although, happy to report this issue was only occurring in the day 1 PC demo, and is fixed in the final release.

PC Controls

So no, this isn’t completely fixed. The ‘downshift’ as default thing is, but the Custom Mapping inputs being completely broken is still very much there. Bizarre mandatory assignments(that shouldn’t be mandatory and aren’t used in default configs) are still there, many inputs straight up dont work when assigned(map is impossible for me to make work) and half the time you save your config and go, you find that you cant even access the Start button/pause menu anymore and just have to Alt+F4 out of the game and redo the controls to something that hopefully works when you reboot it.

This is quite maddening.

PLEASE FIX THIS DEVELOPERS!!! every day i have to alt-f4 out of the game because i accidentally press a button on my controller. [Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D]!

They don’t have the menu for controls how it used to be anymore and I can’t fix it on my console. I have all of the needed controls but they don’t work like they used to and I just want it back to normal. I went to another layout and for some reason it reset the default one. I like tuning and I can’t properly go through my tuning menu anymore

I cannot put into words how infuriating it is not to be able to invert your buttons…like who the hell puts their up shift button BELOW their down shift button… I honestly can’t even play the game because every time I need to down shift in a corner I up shift…and when I need to up shift in a straight…you guessed it, I down shift

I tried to make a custom config once with the analog sticks swapped… It wouldn’t let me save the config because I hadn’t assigned every required command. Even though the default schemes have 2 to 3 functions on each of the d-pad buttons, the same config is impossible to re-create in “Custom 1”.

Same here, it’s a bit broken now and I can’t do what I need. No map for me :smiley:

Same issue here.

ADDRESS CONCERNS COMPANIES

Bumping a month old post? That’ll get your point across /s.

1 Like

A year later and still no one at Playground gives a damn.

Thanks a lot.

I want my money back

Go ask for a refund, you are entitled to try it.

If you want your money back, then I’d suggest you stop playing the game before you ask.

yes I don’t use Anna or Rewinds, but I have to assign them. I had a layout in mind, but wasn’t allowed to use it.

And yet someone took heat for making a fresh post.

Anyway, its not a month old.

Its a year old. Playground have been ignoring this issue for a year.

I have a wheel with less buttons than a lot of current logitech ones, and for some reason I need to have an anna or quick chat button set, which are stupid. On top of that the multiplayer is super buggy. I want my money back