Bug after track expansion update?

Hi, I was a few races into the Prototype 1 series yesterday. Started with the update today and continued the series. Raced two or three tracks and when I got to the 5 racess remaining “next event” screen no event information is being shown. No game mode, no destination or ribbon information, all blank. Pushing A to continue crashes the game. Restarted it and tried several times, same thing. I did go race Road America in another series that I had completed then tried going back to Protoype 1, no change. Help!

My buddy ran into the exact same issue last night when he got online after the update! He was five races in the night before and jumped online last night and it keeps crashing his game. He tried switching cars and still having the same issue. He was able to run events through the league select, but he is unable to continue his career.

Hopefully T10 will catch this and work out a fix. I see somebody else posted a similar issue in the R series. Maybe a button to reset a series when a glitch like this happens?

Same thing is happening to me in the GT races in the racing series. Right after the update. I got 4 races remaining and when I try to start the race it boots me out to the XBOX home screen.

Me also. Did two races in class comp series and game crashed back to xbox home screen. Now I can’t do anything with career. Even league select crashes the game for me. Any1 else with this problem. I have even uninstalled game and update and reinstalled and still same problem.

Problem with career won’t let me get past certain race in e21 races so won’t let me complete this series how can I fix or can someone help

They are now aware of the problem as repoted in the following forum: http://forums.forzamotorsport.net/turn10_postst3970_Road-America---Problems-with-update-while-in-the-middle-of-a-series.aspx