Broken Championship

I’ve long since done all exhibitions and am trying to do championships at all locations but now one is broken. It has four races and I won the first, but when I go to the other three I can’t continue the championship at any of them. They’re the right locations and are marked on the map as being championship races, but when I try to continue the championship there’s only the option to do exhibition (already checkmarked as completed) and Rivals with a padlock on the championship. I try to have Anna select the next championship location but she just suggests street races nearby.

I previously started the championship but found my car had too little speed to be competitive at all so aborted to tweak my setup. When I went to the first race it wouldn’t let me resume so I abandoned the championship and started over. Then I won that first race only to find I can’t continue at any of the remaining locations.

I tried searching topics for “championship” but get over 9,000 (not literally) results for the topic “Drivatars are ruining this game”. We need an option to search just thread titles.

Did you start the championship in someone elses co-op campaign?

If so you may have started a championship you have not unlocked yourself yet.

Do you have an option when at one of the locations to quit championship? Or try to finish in co-op.

No, it was solo plus I’ve unlocked all championships a long time ago. I have the option to quit the championship. I just don’t want to quit but rather resume. If I quit and try again, I might keep encountering this.


I shut the game down completely and rebooted it. Upon loading in and driving out of the festival, Anna told me I was part-way into a championship and asked if I’d like her to set a route to the next race. I agreed and drove to where she took me. It let me resume the championship. Prior to the reboot, I tried there and the other two locations and it wouldn’t let me continue. Must be a bug but at least a reboot seems to remedy it.