Anyone have found fix for stuttering?

It’s a long time since the game relase, but there are still huge problems with stuttering. And this is not problem with PC configuration:
i7 4770k
GTX 980
SSD drive

GPU usage looks like mountains, it’s not straight as it should be, when I experience huge stuttering and frame drops. CPU is not even working hard. GPU memory usage is very high, but it’s not toped out. I play at 2560x1440, but I experienced stuttering even when I was playing on Full HD and memory usage was much, much lower. And if it would be a problem with hardware, I’d experience it in every race, not in just most of them or it would not start at last laps of an hour race. Tried playing with no MSI Afterburner, tried turn off G-Sync, there is no energy saving mode on, Win 10 game mode is off.



Also tried tried to uninstall whole game and install that 100GB again, but everything was the same. GPU drivers are regulary updated.

So, anyone have any idea how to fix this?

Set the Performance Target to DYNAMIC :wink:

This fixed it totally for me
Reddit performance profile

I tried forcing the physics calculations to the GPU but that didn’t do anything. Game is unplayable for me.

GTX 1060
i5 7600

I think I may have found the problem.

When I installed the new Nvidia driver, it set the power management mode to Optimal Power. Apparently that’s the new default mode.

I set it back to adaptive and it’s gotten better. There are still a few stutters here and there but at least it’s not unplayable anymore.

Nothing seems to work for me. The problem (very frequent stuttering, let’s say 5/10 times per lap) appeared suddenly (after Windows 10 April Update… could that be the reason?). I have High End PC with 16GB and GTX 1070. All other games run great - also Forza 3 Horizon runs really smoothly at stable 60fps

What I tried:

  • Enlarge PAGEFILE to 3200Mb
  • Rolled back video driver to earlier version
  • Remove NVIDIA G-Sync
  • Remove Windows 10 Game Bar and Game DVR
  • NVidia Power Management to Max Performance
  • Windows 10 Power Management to High Performance

Any advice?

Yes, see

As much as I don’t like to say it, but only rolling back to update 1709 resolved the issues for me. Similar sys to yours btw (i7 8700, GTX 1070, 16GB 3200)

1 Like

Yeah, stuttering came back today. Power management didn’t help apparently.

Nothing helped for me. Dynamic graphics settings, changing power mode, drivers. Nothing… It all seems like this game just have huge problem with itself and no one try to fix this.

1 Like

My rig is: i7 8700K, GTX1060 6GB, 8GB RAM…and the game lags like hell. I experience huge fps drops in every 3-4 seconds, the whole thing is unplayable. I’ve tried every setup, dvr disable, even nVidia power management tool, but nothing helps.
Im really disappointed.

1 Like

Check the task manager and see if when you have lag spikes you have the cpu or the gpu maxed out. The only advise I would give you is to get 16GB as soon as possible. Even without highest settings i get 9GB of RAM used, so maybe that’s your problem.

First off 8 gigs of ram is not enough. You need at least 16 and if you wanna play it say go for 32, that way Windows never needs a page file. Next why pair an i7 8700k with a 1060? Huge bottleneck.

I play with an i7 5820k, 32 gigs of ddr4, a gtx 1080fe, and i run the game off an intel nvme pcie ssd.

The game is set to run at 4k HDR with everything at ultra in dynamic mode. In afterburner my core OC is +220 and my memory is +200. I never drop below 60fps or see any studdering.

So…if someone has an issue its probably an issue on their system. Something is stealing resources and causing the issues. That or the hardware cant handle your settings. I suggest a Windows reset then install all the basic programs you need like steam, afterburner etc… then download Macrium Reflect and make a system image so you can restore it anytime you feel your system is sluggish and the best part is all your stuff will still be there and all setup plus chances are your games will run better.

Always a good idea to wipe the OS every once and a while. It gets cluttered and its not microsoft’s faults its ours and sloppy devs

I genuinely wish you all good luck fixing this but trust me….its NOT the game

dont pressing alt+tab or alt+enter (switching the window) helps here. when i do so, it will start stuttering most of times. and switching the monitor HZ did help to reduce cases of stuttering.

Same here for me. The 1803 windows update broke the game. When you start a race it lags and stutters every second and is unplayable. Tried different AMD drivers and graphic setups but nothing solved the problem… so I also rolled back to 1709 where the game runs perfect. (Ryzen 5 1600, 8GB RAM, Radeon RX 580)

1 Like

Recently rebuilt my pc with ryzen 7 from i5 and decided to play forza 7 again after 2 months. I was not prepared for how [Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D] the game is running atm. I know its definitely not my CPU because its running below 30% when the game is actually not stuttering and is playable, and my i5 even while watching youtube never had stuttering this atrocious. It seems that for the first 20 minutes of playing the game it runs perfectly but after those 20 minutes it just goes to a stutter [Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D].

My game literally disconnects me from multiplayer because of how bad I stutter while racing. GTA at max settings is way more taxing than forza 7 on my PC yet that game runs flawlessly even with 20+ tabs open on chrome. I hate how us peeps on PC r having basically a repeat of what happened last year with horizon 3 regarding performance issues, hopefully this gets fixed soon.

BTW has anyone tried opening game bar with Windows key + G in forza 7? i cant confirm if game mode is on or off…

To do this, you hve to enable this. My system is not in english, so names may be different.
Go to settings, then “playing” (Xbox icon), then Game Bar or something like that and there should be option “Record clips from game, screenshots… with Game Bar”. You have to enable this one.
It should be working after that.

Sorry I should have been more clear but game bar works for other programs with the exception of forza 7. Like in horizon 3 I can open game bar as well as gta v, chrome pubg, etc but not in forza 7

I think it must be something at your end. I’ve had two PC builds, one mid range (i5-4670, 16gb 1333 and 1060 6gb) and one high end (spec in sig) and neither have had this issue, playing at 4K. (dynamic high, 60fps @ 100% res scale for older one, everything maxed ultra 60fps @ 200% res scale for the new one)

I don’t think it’s on our end. I also have two rigs. The mid one with an i5 6600k oc’d @4.2, 20gb ram and a GTX 1070. My other one with very similar specs as yours, asus rog strx z370 E, i5 8600k oc’d @4.5ghz, 16gb 3000mhz ram and an msi gtx 1080ti Gaming x.

Both of the are doing the same. Previously even my gtx1070 machine ran this game with zero problems at 1440p.

For those interested here is what happens when I attempt to play the game longer than 20 minutes. BTW the car shown is not even my own car, which is another problem forza 7 has (displaying hud view of someone elses car, not your own).

btw specs are

GTX 1060
r7 1700
16gb ddr4 2666