[ANSWERED] Unable to pre-load Forza Horizon 4

When I try to pre-load FH4, I get an error saying “Ten of your devices have apps & games from Store already installed on them. That’s the limit. Go to Store > Settings > Manage your devices. Then remove a device to make room for this new one.”
However, I’ve got only 2 devices. I’ve reached out to the Xbox on Win 10 support and after trying to resolve the problem, the agent directed me here.

Issues

  1. I’ve received a notification from bank regarding the payment, I’ve checked and $100 has been debited from my account, however got nothing from Microsoft. I expected a receipt, like the one I got after ordering Horizon 3.
  2. “The device limit reached” error, as said above.
  3. A windows notification says “Couldn’t install. We’ll try again shortly”. It appears every 5 seconds or so. Other apps, FH3 example, are installing fine.

I’ve tried resetting Win Store, it didn’t help in this situation. On Microsoft order history page FH4 doesn’t show “completed” and for some reason I can still change how I can pay.

Specs if it helps:

i7 8700K
16GB RAM
GTX 1080
Windows 10 version 1803 (17134.285)
Nvidia driver version 399.24
About 3TB free space on HDD and about 300Gb on SSD.

If anyone can shed some light on this issue, I’d be extremely grateful.
Thank you.

2 Likes

I had same issue. Try to creat new windows user profile it worked for me.

Same issue here. I’ve contacted xbox support team and they’ve sent the issue to the internal team for a full investigation. My FH 3 works fine as well.

SAME ISSUE !!! ANY idea what to do ? help appreciated man :C. I downloaded n playedthe demo but when i try to preload the game same issue crops up. And i have 1/10 devices conected only

1 Like

I have the same problem. Tried wsreset, that admin powershell command and a few other things but there is very little info and nothing helps

1 Like

Contacted Support team. They said they reported the issue to the team and can’t give a time frame for a solution but are working. Haven’t hesrd any updates yet though.

P.S. I tried creating a new user profile n then logging in Windows store worth my MS account from the new profile but still failed.

And the billing info allows me to change payment too so don’t know if that’s the reason. Like maybe they are gonna debit the amount when the game releases or something and then the problem fixes. Have no idea tbh

It just fails Everytime when I try installing and that error crops up. N I just have 2/10 devices :confused:

I have the same issue on my pc but when I tried it on my brother’s PC it downloads with no problems. So it’s not about the account or purchase status it about the pc itself.

Same problem here, all other games can install fine, also can pre-load on all my other devices (even a Surface), but for my only gaming PC I get this error.

Also doesn’t work: Re-installing Windows fresh (or restoring previous backup), resetting/clearing Store cache, logging out of the Microsoft account, unplugging one of the hard drives, returning the game and buying again.

Now I’m guessing it’s either tied to a specific set of hardware or the Windows activation itself.

Very frustrating.

Spec:
Laptop-Sager
i7-6700
GTX 1080
16GB
Nvidia Driver 411.63

I’m coming of off a 3h session with the Microsoft support and they were able to solve my issue.

I will try to describe what they actually did as well as I can. Here we go…

  1. Go to https://account.microsoft.com/devices?fref=home.card.devices

  2. Under each device click on ‘more actions’.

  3. Click remove pc for every device.

  4. Open windows start menu and type in ‘wsreset’ run it and wait until Microsoft store opens.

  5. After Microsoft Store is up and running try downloading the game.

This heleped me, I hope it fixes your issue as well. Good luck!

3 Likes

Confirmed!
One tip: when MS Store launch after resetting cache by “wsreset”, relaunch game downloading manually, because error may still be, but it is just a “last error” status.

1 Like

I may have missed that, the support technician from Microsoft was actually doing it for me remotely as in he was controling my pc so I my have missed a step. Thanks for the correction!

Just popping in to say that this worked for me as well. I could not preload because of unknown error and this solved the issue. Hopefully it will be downloaded before tomorrow release.

MATIBET ! IT WORKED !!!

YOU LIL PIECE OF AMAZING HUMAN BEING ! IT FINALLY WORKS !
XD

1 Like

Ha! I had the same reaction when finally one of three support technician was able to start the download on my pc! It took me 2 days 4 windows reinstalls and 3h of ms support chat but it’s finally working!

Thanks for posting guys. I stickied the other thread. [INVESTIGATING] ERROR FIX: 0x803F81F5 - Too many devices - Community Support - Forza Motorsport Forums

This did not fix my problem :frowning:

Have you tried rebooting your PC after you deleted the devices? and did you delete all devices? This is very important as some users left their device on the list and it also didn’t fix for them. They had to delete all devices.

Nothing works either, tried all of the suggestions here and all over the net, but it still gives me “too many devices” even if I have 1 or even NONE. Really sad.

For those of you who are still experiencing pre-load issues, what worked for me was just Installing it on the C: Drive (AKA where Windows is Installed). I’m gonna move it to my other drive once it’s finished downloading using the Windows App Move tool.

Still not working for me after trying to install on C: drive, deleting all devices and creating another user account. Wsreset didn’t work for me neither…

UPDATE: after 00:00 hours, I retried, and download starts…