[ANSWERED] - Creative X-Fi Cards

Exactly after the Turn 10 intro finishes, and menu music starts, the audio sounds a bit distorted and with some crackling.
Tried restarting the pc, through headset, through speakers, to turn off music, nothing works


exactly the same thing happens here, first I thought it was my speakers that was faulty, but it’s only happening in the forza horizon 4 Demo.

Sounds like an old tv, with the crackling sound, hope this gets fixed, it’s both in the menu and in the game while driving aswell.


+1 this worked for me.

I’ve solved it here. Try what I did and see if it works for you:

Right click the speaker in the tray and go to your audio devices.
Right click your speakers and choose Properties.
Click the Advanced tab.
Set it to 16-bit, 48000 Hz (DVD Quality)
Hit OK all the way out.



Man, it worked!! Thanks a lot!

But sure Playground should fix this problem so users with other speakers properties don’t find that problem. Anyway, thanks again!!

i found this out myself but wow so weird that that of all things was the cause of the problem, I had mine at 44100Hz, changed it to 48000Hz and it instantly sounded clear lol

Thanks for the solution

Exact same issue here as raptorscream related. My PC system details on the image.

The solutions aren’t working for me

Same for me. I have a Creative SoundBlaster X-Fi Titanium and tried all settings from 16 Bit 44 KHz, to 24 Bit 48 KHz upt to 32 Bit 192 KHz. Please help!

same here for me. First it was no sound so had to untick disable enhancements. which worked because i have sound but now it sounds like a horror movie. I have tried the above settings, also restarting pc after each attempt but to no avail. I only bought this yesterday and now i can’t play it ( well at least not to its full extent )

Same card, same problem. Funny thing is, the card is more or less just a passthrough these days with filtering\processing over whatever windows sound driver passes on to it.
Fatality pcie version

I’m on the same boat…

Same here with a X-Fi Titanium. Workaround for me was to plug in in my headphones into my onboard sound.
I hope Playground can fix this.

I have creative too. tried everything

When setting your audio to 24bit 44100Hz, players may experience a static or crackle sound. This does not happen on any other setting.

Yes, it does, unfortunately! I have set mine on 16 Bit 48 KHz and the sound is still distorted. I tried all settings all the way up to 32 Bit 192 KHz. The issue still persists and it’s the only game I have this kind of issue. I have a CreativeLabs X-Fi Titanium.

1 Like

Same circumstances as others with Xfi, I have the fatality version with Windows 10 1803, xfi Driver Version 2.40.15.
Tried each of the quality options mentioned previously, but also went into the sound blaster control panel and disabled all processing (literally pass through mode).
Switching to my realtek on-board audio, it works fine, except for the quality option you mention here.
Anyway, thought i’d mention in better detail what i’ve tried to resolve it. Hope it gets fixed soon, as i can’t play racing games well without audio feedback, but its also too bad to ignore entirely.

Please correct this on the known issue. It actually happen in all configuration, not only 24 bit 44100Hz.


Come on Playground…

I repeat myself:
Please correct this on the known issue. It actually happen in all configuration, not only 24 bit 44100Hz.

And fix this bug !

it’s been 2 weeks since the demo came out … Will I have to complain to microsoft that I can not play a game included in the xbox game pass and have to request the refund of my xbox game pass ?